mcarterbrown.com  

Reply
 
Thread Tools Search this Thread
Old 12-19-2009, 10:46 AM   #1 (permalink)
Freemason
 
cave_hero's Avatar
 
Join Date: Jun 2007
Location: Central texas

CCM Fan
AKA Fan
Palmers Fan
Classic 68 shooting hot

I have an older mag with a classic 68 valve, it hasn't been used in awhile and when I pulled it out to play I couldn't get it to shoot under 300fps on co2. I cleaned it real good but no dice, should I get the rebuild kit with the main spring or is there maybe a different problem?

Thank you
cave_hero is offline   Reply With Quote
Old 12-19-2009, 10:53 AM   #2 (permalink)
WVU paintball #19
 
minimag03's Avatar
 
Join Date: Aug 2006
Location: Morgantown, WV

AKA Fan
I doubt the main spring has much to do with it. It just recocks the bolt.

I have never had this problem, but would guess it is the piston acting up.
minimag03 is offline   Reply With Quote
Old 12-19-2009, 12:23 PM   #3 (permalink)
Canuck Automagger
 
Epic_Scotsman's Avatar
 
Join Date: Mar 2008
Location: Outside Montreal
Send a message via MSN to Epic_Scotsman

if you get a new mainspring that can help but the above may be true aswell. IF your mainspring is really worn it won't put up enough resistance.
__________________
Epic_Scotsman is offline   Reply With Quote
Old 12-19-2009, 03:57 PM   #4 (permalink)
Marathoner
 
secretweaponevan's Avatar
 
Join Date: Aug 2007
Location: Pocono Lake, PA

Did your velocity adjuster work at all?
Did this valve ever have a level 10 bolt kit in it?

A leaking reg seat (the squared-edge donut seal) would cause an increase in pressure, but even then, a properly-functioning piston would vent out the back.

It could also be due to a spring pack that is crammed with dirt or debris.

Either way, your reg piston is designed to vent if pressures get too high.
__________________
"You don't use science to show that you're right, you use science to become right." -xkcd 701
feedback
secretweaponevan is offline   Reply With Quote
Old 12-19-2009, 07:35 PM   #5 (permalink)
Freemason
 
cave_hero's Avatar
 
Join Date: Jun 2007
Location: Central texas

CCM Fan
AKA Fan
Palmers Fan
I believe it never had a level 10 in it. Aside from general cleaning and oiling what should I try?
cave_hero is offline   Reply With Quote
Old 12-19-2009, 07:39 PM   #6 (permalink)
Marathoner
 
secretweaponevan's Avatar
 
Join Date: Aug 2007
Location: Pocono Lake, PA

Did your velocity adjuster work at all?
__________________
"You don't use science to show that you're right, you use science to become right." -xkcd 701
feedback
secretweaponevan is offline   Reply With Quote
Old 12-19-2009, 07:40 PM   #7 (permalink)
WVU paintball #19
 
minimag03's Avatar
 
Join Date: Aug 2006
Location: Morgantown, WV

AKA Fan
I'd try messing with it again before ordering a new piston. Check the oring on the piston and the spring pack. CO2 makes them shoot a little bit faster than HPA, but not stop you from getting below 300fps. If all else fails, a new piston is what should be replaced first.
minimag03 is offline   Reply With Quote
Old 12-19-2009, 11:30 PM   #8 (permalink)
Freemason
 
cave_hero's Avatar
 
Join Date: Jun 2007
Location: Central texas

CCM Fan
AKA Fan
Palmers Fan
The velocity adjustment works, I can screw it in and back out.
cave_hero is offline   Reply With Quote
Old 12-20-2009, 12:56 AM   #9 (permalink)
Marathoner
 
secretweaponevan's Avatar
 
Join Date: Aug 2007
Location: Pocono Lake, PA

Quote:
Originally Posted by cave_hero View Post
The velocity adjustment works, I can screw it in and back out.
Does the velocity go up and down when you do that?

How high and low does the velocity go when you do that?
__________________
"You don't use science to show that you're right, you use science to become right." -xkcd 701
feedback
secretweaponevan is offline   Reply With Quote
Old 12-20-2009, 07:12 PM   #10 (permalink)
Bitter Young Man
 
HyePower's Avatar
 
Join Date: Jul 2008
Location: San Francisco, CA

Take out the regulator adjusting nut, then take out the piston. Clean it and grease it up again with some white lithium grease or something like it. Then put it back in and see what happens.
HyePower is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Air Gun Designs

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 01:28 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC