mcarterbrown.com

mcarterbrown.com (http://www.mcarterbrown.com/forums/)
-   Air Gun Designs (http://www.mcarterbrown.com/forums/air-gun-designs/)
-   -   Project mag coming... what fixes? (http://www.mcarterbrown.com/forums/air-gun-designs/11586-project-mag-coming-what-fixes.html)

aqua_scummm 02-24-2007 07:37 PM

Project mag coming... what fixes?
 
So I have a project mag coming from a trade. Supposedly it leaks down the barrel. The valve halves do not match, and the star is already used. The owner said it leaked when he got it back from AGD, but for some reason he did not send it back to them...

Would a parts kit generally fix this? Any recommendation on which kit to get? Where should I start replacing things first?

It's a classic valve with a level 7, if that matters.

Surestick 02-24-2007 08:12 PM

My semi-educated guess:
Most likely powertube o-ring (and a parts kit would fix it).

Unless something catastrophic happened to it a parts kit should fix pretty much any problem short of a worn out sear or bolt-lip.

If it's an old powerfeed mag you will want to make sure it has the parabolic powerfeed plug. Changing that made a world of difference in how well mine feeds.

Havocx 02-24-2007 08:36 PM

try oiling it first before you get the parts kit. I mean oil the valve ports and then put some oil in the asa and shoot a dozen times if it still leaks then get the parts kit

aqua_scummm 02-24-2007 09:57 PM

I'll probably grab a parts kit first, I never feel right bringing a marker without a kit that can fix 99% of issues (I bring a soldering iron... and I don't even own a semi-auto as of right now...)

But I will definitely try some lube first.

Thanks

Wollffy 02-24-2007 10:03 PM

fix
 
Hey Aqua I recently had some barrel blowout issues with one of my Mags. I was able to fix her up just by switching some of the orings. This was a pointer given to me by an AO tech who calls himself Tuna. Let me know when you get it I can probably give a little advice.

AGDRetro 02-25-2007 09:23 PM

aqua, I noticed that same screen name over at Velocity Paintball's forums where I go by CRSteve. If youre in the Ephrata area I might be able to help... let me know!

rudz 02-28-2007 01:02 AM

put some oil in the asa, if that doesnt work try looking for worn o rings

aqua_scummm 03-13-2007 03:02 AM

Ah, it was a suprise. No On/Off top, it was completely missing. Ordered one from AGD today

rudz 03-14-2007 12:34 PM

lol, wow that is a suprise


All times are GMT -4. The time now is 05:09 PM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC