mcarterbrown.com
 

Reply
 
Thread Tools Search this Thread
Old 05-20-2010, 02:15 AM   #1 (permalink)
Post Whore
 
StealingYerMail's Avatar
 
Join Date: Nov 2008

Trigger seems... slow

I'm running an AIR valve on co2, but for the testing I used an HPA tank with about 2000psi in it.

Anyway, I originally head a leak down the barrel, solved with a new o ring in the powertube. But now I have noticed that my trigger (this Mag has a double trigger, like on a Tac-One, but is stock) seems sticky. Such as I'll pull it back, and the RT will be slow to kick the trigger back into position. What's up with that? It makes my Mag feel a lot less responsive.
StealingYerMail is offline   Reply With Quote
Old 05-20-2010, 02:32 AM   #2 (permalink)
Not a Squatch...
 
Timber_Ghost's Avatar
 
Join Date: Jun 2009
Location: Peoria, IL
Send a message via AIM to Timber_Ghost

What output pressure is your tank you are using?
__________________
MY FEEDBACK
Timber_Ghost is offline   Reply With Quote
Old 05-20-2010, 02:50 AM   #3 (permalink)
Post Whore
 
StealingYerMail's Avatar
 
Join Date: Nov 2008

800psi. Never had this problem until about the time the leak started to happen.
StealingYerMail is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Air Gun Designs

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 06:26 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC