mcarterbrown.com  

Reply
 
Thread Tools Search this Thread
Old 10-03-2010, 10:43 PM   #1 (permalink)
Active Member
 
Join Date: Jul 2010

level 10 problems (for real)

So I've been having a bunch of issues with my xvalved mag. Refer to this thread for details:

X valve w/ Level 10 - Problems

Now I'm having some more issues with it:

1) Sometimes goes full auto, tried taking out ULT shims doesn't help. Changed o rings (in the ult), doesn't help. Sometimes it starts working fine, not sure what's wrong?

2) Sometimes after shooting a stream it'll just refuse to shoot amd pulling the trigger does nothing. Have to manually reset the bolt (it's only like 1mm away from where it clicks in)

Set up is 2 shims in the level 10 and 2 shims in the ULT. Velocity is up all the way with the stiffest spring. Have the 1.5 carrier in there and it fits very loosely but doesn't leak.

Any ideas? Thanks guys
denisizzle is offline   Reply With Quote
Old 10-03-2010, 10:46 PM   #2 (permalink)
Not a Furry
 
Clearush's Avatar
 
Join Date: Mar 2006
Location: HTown, Texas
Send a message via AIM to Clearush

worn sear??
__________________
Black Watch Scenario Paintball Team , MCB Feedback
Carter's Commando Texas division
Clearush is offline   Reply With Quote
Old 10-03-2010, 11:11 PM   #3 (permalink)
Active Member
 
Join Date: Jul 2010

sear looks perfect to me, nice sharp edges. I turned down the velocity and slowly turned it up just till it will start shoot and it no longer goes in full auto but the recharge rate is very slow, if I shoot to fast it'll just stop shooting and do nothing when I pull the trigger until I manually push the bolt in a little bit till it clicks.
denisizzle is offline   Reply With Quote
Old 10-03-2010, 11:13 PM   #4 (permalink)
Active Member
 
Join Date: Jul 2010

I should also mention that the sear rod behind the trigger can move up and down not just in and out. Not sure if this is the problem.
denisizzle is offline   Reply With Quote
Old 10-03-2010, 11:25 PM   #5 (permalink)
mag shooter
 
superman's Avatar
 
Join Date: Jun 2007
Location: Charleston, SC

do you have a rail bushing?
__________________
I buy Automags and Parts: if you need cash shoot me a pm

feedback(http://www.mcarterbrown.com/forums/f...-feedback.html)
superman is offline   Reply With Quote
Old 10-03-2010, 11:53 PM   #6 (permalink)
Five four three two one
 
onecaribou's Avatar
 
Join Date: Mar 2008
Location: Columbia,SC

Have you checked the length of the sear rod? Should be adjusted so that you can just fit a credit card between the end of the rod and your trigger when aired up.
onecaribou is offline   Reply With Quote
Old 10-03-2010, 11:57 PM   #7 (permalink)
Active Member
 
Join Date: Jul 2010

Quote:
Originally Posted by onecaribou View Post
Have you checked the length of the sear rod? Should be adjusted so that you can just fit a credit card between the end of the rod and your trigger when aired up.
Yep with the safety on the rod is the proper distance but the trigger moves back and forth so without the safety on it'll usually be touching the rod.

What is rail bushing?
denisizzle is offline   Reply With Quote
Old 10-04-2010, 12:00 AM   #8 (permalink)
more gooder
 
dukie's Avatar
 
Join Date: Apr 2008
Location: Kitchener, Ontario

Fan of EMR
CCM Fan
Quote:
Originally Posted by denisizzle View Post
Yep with the safety on the rod is the proper distance but the trigger moves back and forth so without the safety on it'll usually be touching the rod.

What is rail bushing?
You measure the gap with the marker gassed up, trigger forward if it has any slop, and safety off.

The rail bushing is in the rail where the thumbscrew goes through. It sticks out the bottom and slips into the back hole of the trigger frame.
dukie is offline   Reply With Quote
Old 10-04-2010, 12:09 AM   #9 (permalink)
Active Member
 
Join Date: Jul 2010

Quote:
Originally Posted by dukie View Post
You measure the gap with the marker gassed up, trigger forward if it has any slop, and safety off.

The rail bushing is in the rail where the thumbscrew goes through. It sticks out the bottom and slips into the back hole of the trigger frame.
gap looks ok and there is plenty of rail bushing.
denisizzle is offline   Reply With Quote
Old 10-04-2010, 07:53 PM   #10 (permalink)
Active Member
 
Join Date: Jul 2010

can it be a problem with a bent on/off pin? (looks straight but I'm not sure. Or should I change all the o rings in the on/off?
denisizzle is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Air Gun Designs

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 01:53 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC