mcarterbrown.com

mcarterbrown.com (http://www.mcarterbrown.com/forums/)
-   Air Gun Designs (http://www.mcarterbrown.com/forums/air-gun-designs/)
-   -   My classic lives ! (http://www.mcarterbrown.com/forums/air-gun-designs/201603-my-classic-lives.html)

Honk 05-05-2012 12:32 AM

My classic lives !
 
So long story short I read spider's post and shimmed up my banjo bolt. Seem's to be shooting great now. I appreciate all the help I'v received in this forum. I intend to play with it tomorrow and we'll see how it goes.
Also if anyone is looking for a Galactic Z mag like that sex machine Robertsr just built there is one for sale local to me. I can get pic's and what not if somebody want's it.
Thanks many times over for the patient responses.
Honk

Spider! 05-05-2012 07:00 PM

:clapping:

Mark the edge of the banjo so you can keep track of it. If it ever leaks again, it will be useful to know either way.

RT's R fun.

However, I think I pulled a muscle in my shoulder one-handing it on a run. :rolleyes:

Honk 05-05-2012 08:53 PM

It shot like a champ today accept sometimes the trigger pin get's stuck in the back position. I'm about to change the on/off pin and see if that cures it.

Spider! 05-05-2012 09:00 PM

Mine hung up the other day, but only because the level 10 couldn't shove the swollen paint into the j&j barrel.

Honk 05-05-2012 09:57 PM

I have a lvl 7 still, but only one chop today, and I wasn't shooting it when it happened. I looked at my trigger rod and it look's like it's getting turned in when i shoot. I ran it out a but and blue loctite'd it. I'll let ya know how it goes. :D

Honk 05-06-2012 01:04 PM

So loctiteing my trigger didn't fix it. The gun cycles fine then it fire's and the trigger pin dosn't come back forward. I changed the on/off pin. If I take the air off then put it back it reset's the valve and cycles fine afterwords till it get's stuck again. Any advise ?

henchman 05-06-2012 03:56 PM

Did you try oilng the gun?

Honk 05-06-2012 06:49 PM

I'v poured a lot of oil in this mag lol. It don't help, I still get the trigger stuck.

Spider! 05-06-2012 10:02 PM

Is the bolt spring good?

That and the little o-ring inside the RT on/off can get old and cranky.

Mine also had a build up of crud on the edge of the body washer. I thought my level 10 wasn't fitting because of the tip (kind of), but as I sanded the inside down, it went surprisingly quick up to a point, as I got down to the actual washer.

Honk 05-06-2012 10:40 PM

Well, as I took it apart to look at the spring I noticed my tip was loose in the end of the power tube. That could be a problem lol. I'll get air Tuesday and see where that got us. I did change the spring though.
Thanks
Honk


All times are GMT -4. The time now is 12:50 AM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC