mcarterbrown.com

mcarterbrown.com (http://www.mcarterbrown.com/forums/)
-   Air Gun Designs (http://www.mcarterbrown.com/forums/air-gun-designs/)
-   -   level 10 issue (http://www.mcarterbrown.com/forums/air-gun-designs/218783-level-10-issue.html)

samthepainter 11-16-2012 08:54 PM

level 10 issue
 
I got a LX a while back off the BST, problem is, it wont shoot at all. It airs up, but nothing even happens when I pull the trigger. What's the likely problem? Do I have to buy a LX tuning kit?

Ando 11-16-2012 10:29 PM

Bump up the velocity. It take more pressure to run the lvl 10 then it does a lvl 7 and more then likely you're going to need more then just the one carrier you have for tuning it.

RatFink 11-16-2012 10:43 PM

Will the valve body fall out, or almost fall out if you hold the assembly by the bolt? If not, it's probably too tight.

samthepainter 11-16-2012 11:36 PM

Quote:

Originally Posted by Ando (Post 2536284)
Bump up the velocity. It take more pressure to run the lvl 10 then it does a lvl 7 and more then likely you're going to need more then just the one carrier you have for tuning it.

This is a completely different valve than my lvl 7, i didn't put a new bolt on my old valve. Adjusting velocity didnt affect anything.

Are lvl10 carriers different than lvl7 carriers?

Quote:

Originally Posted by RatFink (Post 2536294)
Will the valve body fall out, or almost fall out if you hold the assembly by the bolt? If not, it's probably too tight.

it does

ta2maki 11-17-2012 12:59 AM

This is a stupid one, but have you taken the gun apart? I've noticed that when I have some of my mags sitting for a long while, The bolt sticks to the rubber bumper enough that it won't shoot. All I have to do is remove the valve and pull off the bolt from the valve and put it all back together.

samthepainter 11-17-2012 02:17 AM

Quote:

Originally Posted by ta2maki (Post 2536402)
This is a stupid one, but have you taken the gun apart? I've noticed that when I have some of my mags sitting for a long while, The bolt sticks to the rubber bumper enough that it won't shoot. All I have to do is remove the valve and pull off the bolt from the valve and put it all back together.

i've tried that but thanks :p

dukie 11-17-2012 01:45 PM

try a shorter spring and or turn up the velocity more. I had to crank mine to the point where it would vent originally and it would still not shoot. I had to replace the reg piston ( x valve) to get it to work properly.

level 7 spacers and level 10 carriers are completely different animals. do not interchange them.

the bolt should slide off if you hold the valve body up, not the other way around.

ta2maki 11-17-2012 03:47 PM

Quote:

Originally Posted by samthepainter (Post 2536209)
I got a LX a while back off the BST..

Backing up a bit, what exactly did you buy and what are you putting it in? Did you buy just the bolt or the whole kit? What did you do to put it in, just swapped bolts?

dukie 11-17-2012 10:22 PM

Quote:

Originally Posted by ta2maki (Post 2536757)
Backing up a bit, what exactly did you buy and what are you putting it in? Did you buy just the bolt or the whole kit? What did you do to put it in, just swapped bolts?

good point! A lvlx bolt porbably won't worth a crap with a level 7 tip and spacer in there.

samthepainter 11-18-2012 12:09 AM

Quote:

Originally Posted by ta2maki (Post 2536757)
Backing up a bit, what exactly did you buy and what are you putting it in? Did you buy just the bolt or the whole kit? What did you do to put it in, just swapped bolts?

I bought a valve with Level 10 bolt. I'm sure it's a level 10 bolt and it looks like the level 10 spacer also. The person I bought it from said it was untested, they were just reselling it... I should've known to pass on it :(

All it has is the short (or medium?) spring and i dont have any extra parts

(just checked, it's definitely a level 10 tip


All times are GMT -4. The time now is 12:52 AM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC