mcarterbrown.com  

Reply
 
Thread Tools Search this Thread
Old 03-29-2013, 10:28 PM   #11 (permalink)
E-Tac Operator =
 
Justus's Avatar
 
Join Date: Apr 2010
Location: Illinois

When did hill offer installations? I missed out on that apparently.
__________________
My Feedback
Justus is offline   Reply With Quote
Old 03-30-2013, 06:26 PM   #12 (permalink)
MCB Member
 
Jaccen's Avatar
 
Join Date: Aug 2011
Location: SW Ontario

AKA Fan
He didn't offer the service that I know of. When he switched focus to restoring his car he sold off some of his prototype parts for the hidden eyes Egomag and efficiency inserts. I just happen to grab them.
__________________
MCB Feedback
Please ship to me using US Postal Service when shipping to Canada.
Don't ship to Canada? No worries--I can work it out with you: US Parcel Pickup

Jaccen is offline   Reply With Quote
Old 03-30-2013, 07:04 PM   #13 (permalink)
E-Tac Operator =
 
Justus's Avatar
 
Join Date: Apr 2010
Location: Illinois

Ah, makes sense. Doing the installation and tearing up my X-valve (well, the odd powertube o-ring anyway) was one of the bigger hindrances for me originally.
__________________
My Feedback
Justus is offline   Reply With Quote
Old 03-30-2013, 08:33 PM   #14 (permalink)
lukescustoms.com
 
luke-AO's Avatar
 
Join Date: Aug 2009
Location: Cottonwood AZ

I'm doing installs and now stock in the PT oring.
__________________
My Feedback
luke-AO is offline   Reply With Quote
Old 03-31-2013, 12:00 AM   #15 (permalink)
E-Tac Operator =
 
Justus's Avatar
 
Join Date: Apr 2010
Location: Illinois

Quote:
Originally Posted by luke-AO View Post
I'm doing installs and now stock in the PT oring.
This is true, and I knew that. It just wasn't true at the time I sold my X-valve insert.

Not that I would need any installation service now, though. Seriously, what are the chances of running into an X-valve that comes open by itself and a Classic valve that comes open by itself, all in the span of a couple months? (And neither of these valves leak or have any problems operating - both cosmetically 9/10 easily) I couldn't believe it. I'm just glad I did hold on to the Classic insert at least, since that valve is now going into my 12g powered pump-mag.
__________________
My Feedback
Justus is offline   Reply With Quote
Old 04-06-2013, 10:18 AM   #16 (permalink)
Rec Poster
 
Join Date: Feb 2013

I shredded the powertube oring on mine. I just wrapped some Teflon tape around it and torqued it down good. Works fine, 4 cases later.
brokeass_baller is offline   Reply With Quote
Old 04-11-2013, 09:35 PM   #17 (permalink)
mag shooter
 
superman's Avatar
 
Join Date: Jun 2007
Location: Charleston, SC

i had a valve come to me from pbn that had a strange leak. the powertube was loose. no insert inside. but it was an easy fix after i replaced every oring in the gun and realized what it was.
__________________
I buy Automags and Parts: if you need cash shoot me a pm

feedback(http://www.mcarterbrown.com/forums/f...-feedback.html)
superman is offline   Reply With Quote
Old 04-12-2013, 10:03 PM   #18 (permalink)
Active Member
 
Join Date: Jul 2011

I will have test results from a second installed Classic Valve insert shortly. I will post them in here once I test the new Classic Valve Insert. My previous test results were posted in the original pbnation thread.
Steve_81 is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Air Gun Designs

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 10:10 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC