mcarterbrown.com  

Reply
 
Thread Tools Search this Thread
Old 04-29-2013, 08:10 AM   #1 (permalink)
Newbie
 
Join Date: Jul 2009

Excalibur low velocity

Can't get my 04 Excalibur to shoot above the 270s. Tried a new battery already. Any help would be great
rambo714 is offline   Reply With Quote
Old 04-29-2013, 11:11 AM   #2 (permalink)
Newbie
 
JenkemSurprise's Avatar
 
Join Date: Apr 2013
Location: Norway

Checked the LPR pressure? Made sure the marker is nice and clean internally(IE: No gunky cartridges, and the HPR?) What board are you using, and what settings?

Is this something that just started happening out of the blue, what have you been doing with the marker recently?
JenkemSurprise is offline   Reply With Quote
Old 04-29-2013, 04:33 PM   #3 (permalink)
Newbie
 
Join Date: Jul 2009

My lpr is at 80. I just got the gun. I'm using a tadao ebisu board
rambo714 is offline   Reply With Quote
Old 04-29-2013, 09:49 PM   #4 (permalink)
MCB Member
 
aggroman's Avatar
 
Join Date: Dec 2009

CCM Fan
AKA Fan
Brass N Wood Fan
try another new battery, check your settings and check your paint to barrel match.
aggroman is offline   Reply With Quote
Old 05-02-2013, 03:01 PM   #5 (permalink)
MCB Member
 
Join Date: Sep 2006

I had several issues with Ebisu boards in my excals.

One was velocity issues, another was ROF. Swapping that board out without touching pressures and putting a Pandora w/ rMod4.2 or an m5 in and it was humming along beautifully.

Something to consider.
__________________
MCB Feedback
haxorwear is offline   Reply With Quote
Old 05-02-2013, 04:19 PM   #6 (permalink)
Post Whore
 
Join Date: Mar 2013
Location: Beantown, Kid!

Quote:
Originally Posted by haxorwear View Post
I had several issues with Ebisu boards in my excals.

One was velocity issues, another was ROF. Swapping that board out without touching pressures and putting a Pandora w/ rMod4.2 or an m5 in and it was humming along beautifully.

Something to consider.
Ditto. I run Musashis and Pandoras now with no issues.
Frizzle Fry is offline   Reply With Quote
Old 05-03-2013, 10:41 AM   #7 (permalink)
Newbie
 
Join Date: Jul 2009

ill try that today. I'll let you guys know what happens. thanks
rambo714 is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » AKA

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 06:01 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC