mcarterbrown.com  

Ask The Experts You ask the tough questions

Reply
 
Thread Tools Search this Thread
Old 04-06-2006, 08:51 PM   #1 (permalink)
PJ
Retired from paintball
 
PJ's Avatar
 
Join Date: Apr 2006
Location: Powell, TN
Send a message via AIM to PJ

Question New-to-me Sterling having rough time cocking

I received Blackrain's splash anno Sterling in the mail yesterday. Tried it out and it shot REAL nice, decent pump stroke, and great accuracy. The only bad thing about it was the trigger pull. It has a vertical air spacer bar on it and you either had to yank the trigger back pretty hard or pull it all the way back and then give a last squeeze or jiggle for it to shot. I figured the sear wasn't tall enough with the spacer bar to fire when the trigger was pulled, so I tore into the frame today and wrapped a small piece of wire around the sear so the trigger would push it higher to trip the hammer.

I put the frame back together and back on the body to try it out. The mod worked fine, but the pump stroke was really rough. I didn't take the pump arm off, just removed the frame from the body. The bolt has the setscrew in it to hold the pump rod arm and I tried it with the screw holding the arm and not holding the arm. The pump bound up with the screw holding the arm, but wasn't as bad when it wasn't holding the arm. Is it possible that the timing is off and causing this, or have I possibly bound something putting the frame back on?
PJ is offline   Reply With Quote
Old 04-06-2006, 10:12 PM   #2 (permalink)
Exterminate!
 
WilD's Avatar
 
Join Date: Mar 2006
Location: The Motor City
Send a message via AIM to WilD

Brass N Wood Fan
Palmers Fan
RTP Fan
It is possible something is binding up. Did you modify the "sear" that is attached to the hammer or the trigger? If you wrapped wire around the actual sear, maybe that is draging when the hammer is engaged. It may also be possible that you overtightened the front screw on the frame so it is placing some friction on the pump rod. I recently sold my Sterling so I don't have one to look at but I seem to recall this may be possible. In any case, I don't think this could be a "timing off" type of issue. I suspect you wire mod or something is overtightened.
WilD is offline   Reply With Quote
Old 04-06-2006, 10:33 PM   #3 (permalink)
I am stuck on bandaid...
 
JaKaL's Avatar
 
Join Date: Apr 2006
Location: Orlando, FL

I suspect that it might actually BE a "timing off" issue, because I have a similar vert adapter rail that works fine. Are you sure that the carrier is screwed far enough onto the pump rod?

I think that the binding is most likely related to the wire that you introduced into your gun. The sear slides back and forth inside a slot in the body/rail, and if it's been widened by wrapping wire around it it could be binding in that slot.
JaKaL is offline   Reply With Quote
Old 04-06-2006, 10:38 PM   #4 (permalink)
PJ
Retired from paintball
 
PJ's Avatar
 
Join Date: Apr 2006
Location: Powell, TN
Send a message via AIM to PJ

I don't think it's the wire itself, it was a very thin spring from an Autococker spring set. It's not on the hammer sear, but the (OK, am I using the wrong term here?) sear in the frame that the trigger lifts to trip the hammer sear. Everything sits well below the spacer bar, so it isn't the wire dragging on anything above it. I'll have to check the front screw to make sure I didn't overtighten it. Might be time for a complete teardown to see exactly how far that front screw goes in.

Thanks!
PJ is offline   Reply With Quote
Old 04-07-2006, 10:32 PM   #5 (permalink)
Rec Poster
 
Snyiper's Avatar
 
Join Date: Mar 2006
Location: Lovely Southern Md
Send a message via AIM to Snyiper Send a message via Yahoo to Snyiper

My bet is the front screw...is it the field strip ones or allen head?
__________________
Glenn

Players "Play the game with Honor and Dignity or just wipe cause you suck"
Snyiper is offline   Reply With Quote
Old 04-07-2006, 11:42 PM   #6 (permalink)
PJ
Retired from paintball
 
PJ's Avatar
 
Join Date: Apr 2006
Location: Powell, TN
Send a message via AIM to PJ

It's an Allen head screw - the field strip one wouldn't fit with the vertical air setup. I went ahead and backed the front screw out about 1/2 of a turn and undid the pump rod from the bolt (the bolt is one of the later kind that has the set screw in it to hold the rod arm) and that seemed to help soem. Still a little rough so I'll tear into it this weekend and clean/lube it.

One thing about this one is that the barrel that matches the anno pattern (black w/gold splash) is short. I mean REALLY short, like it lacks about 2 inches or so of clearing the pump arm. I'll get some pictures this weekend of it.
PJ is offline   Reply With Quote
Old 04-08-2006, 01:30 AM   #7 (permalink)
Cheffer
 
jhyan's Avatar
 
Join Date: Apr 2006

ON my sterlings, I cranked down the front frame screw once, and bent the brass piece that the pickup rod rides through. It really messed it up, so I had to re-reound that hole, and now I keep a split washer on that screw so it doesn't go in too far.
jhyan is offline   Reply With Quote
Old 04-08-2006, 01:55 AM   #8 (permalink)
PJ
Retired from paintball
 
PJ's Avatar
 
Join Date: Apr 2006
Location: Powell, TN
Send a message via AIM to PJ

Washers

<head smack> That's an excellent idea! I never like having screws even slightly loose as I've found slightly loose usually will turn into "where the heck did it go?" too many times.
PJ is offline   Reply With Quote
Old 04-08-2006, 03:22 AM   #9 (permalink)
I am stuck on bandaid...
 
JaKaL's Avatar
 
Join Date: Apr 2006
Location: Orlando, FL

PJ, didn't that gun have a freak back? I may be mistaken, but if it is a freak back that'd be why it seems so short. It would need a "front" on there...
__________________
...'cause bandaid's stuck on me!
JaKaL is offline   Reply With Quote
Old 04-08-2006, 07:32 AM   #10 (permalink)
Rec Poster
 
Snyiper's Avatar
 
Join Date: Mar 2006
Location: Lovely Southern Md
Send a message via AIM to Snyiper Send a message via Yahoo to Snyiper

Well if you undid the front screw some and the bolt is disconnested it has to be something with the rod and front guide. Check it real good, like it was said may have tweeked the front guide sleeve...Hope this gets you up and runing.
__________________
Glenn

Players "Play the game with Honor and Dignity or just wipe cause you suck"
Snyiper is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » Ask The Experts

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 03:51 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC