mcarterbrown.com

mcarterbrown.com (http://www.mcarterbrown.com/forums/)
-   Ask The Experts (http://www.mcarterbrown.com/forums/ask-experts/)
-   -   2k5 Intimidator Problem (http://www.mcarterbrown.com/forums/ask-experts/220153-2k5-intimidator-problem.html)

brando247 12-03-2012 07:49 AM

2k5 Intimidator Problem
 
I picked up a 2k5 dark intimidator from a guy on craigslist. Gun airs up and holds air fine. Seems to cycle and fire cleanly, but it isn't firing on every trigger pull. When I don't have air hooked up to the gun, the solenoid seems to be clicking correctly. By correctly, I mean that when the eyes are on the solenoid clicks about 1 second after a trigger pull, and when the eyes are off, it clicks immediately with every trigger pull. But when I air the gun up it will fire for a few pulls and then stop and start again. Sometimes it will fire without me touching the trigger. My suspicion is a bad solenoid, but I haven't worked on one of these in a looong time. Any ideas? And any idea where I can find parts for this thing?

LibertyRadeon 12-03-2012 07:59 AM

Did you replace the battery?

brando247 12-03-2012 08:10 AM

Yes. That was the first thing I did.

Dr. VonDeafingson 12-03-2012 08:35 AM

Call BLAST. They'll have parts and can help you diagnose the problem. Pb gateway and pbnation will probably have the parts too. I know people scout pbnation and build timmies from parts they've bought on pbnation.

brando247 12-03-2012 08:37 AM

Thanks!

Spider! 12-04-2012 09:51 AM

Besides the solenoid being dirty, my old beater had a few problems. One was the switch was dirty. I sprayed some contact cleaner in it before I went to desolder it, and that cured that bit. Early on, a friend was looking at it and dropped the battery out of it, still attached to the harness. I found the power wire just barely connected by a strand or two. Enough to power the board, but not enough to fire the solenoid also without a wiggle.

For lots of 2k5 stuff, look at this old forum as well. They are like AO for timmies.

http://www.intimidatorowners.com/

RatFink 12-04-2012 09:09 PM

Mine does that with too little LPR pressure.

r90t 12-05-2012 12:05 PM

check your eye harness for a pinched wire. I think my 2K4 intimidator would do about 1 ball/sec when there was an I issue. Then bypassing the eyes, it would shoot as fast as you could pull the trigger.

TechPB-Mike 12-06-2012 10:28 PM

that's just a blown frenzy board

VERY common with the earlier board revisions, 1.16 and such.

Send it in the blast to see if they can update it or replace it. Or better yet, get the Tadao OLED board for it... yeah dawg!

brando247 12-13-2012 07:22 AM

Awesome. Thanks guys.


All times are GMT -4. The time now is 07:01 PM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC