mcarterbrown.com  

Bob Long BLAST - Bob Long Action Sports Technologies

Reply
 
Thread Tools Search this Thread
Old 04-30-2013, 11:15 PM   #1 (permalink)
All hail RatFink!
 
RatFink's Avatar
 
Join Date: Jan 2008
Location: Ronapour

Trouble with Empire pressure balanced valve

My 2K5 Timmy worked great, short of it would shoot + or - 15 over the chrono, so I started looking for ways to make it run more consistently. I picked up an AKA SCM as well as an older 2 liter HPR. The regs didn't change a thing. As a matter of fact, as I was tuning them in, I was having a hard time getting the velocity to 280 before falling off from the sweet spot on the HPR. Dwell set to 8 and LPR almost 100, anything lower and it didn't even want to cycle. I decided to try the Empire Pressure balanced valve I had sitting around, thinking, maybe the ram was gummed up and causing my trouble. Now I can't get it to shoot 240 before it starts leaking from the ram and it seems the valve is back feeding my LPR causing the LPR pressure to rise in conjunction with my HPR. If I turn my LPR down too much, it just starts venting out the front and if I turn my HPR down too much, It vents out the barrel and if I turn the HPR too high, it starts venting out of the ram. Any ideas? I have done everything I could possibly think of for now... Oh, and I even tried goofing the crap out of the poppet with Dow 55.
__________________
Quote:
Originally Posted by Wraith View Post
If you can't be bothered to pick up your 12 grams, you don't deserve to be playing on a field. You have pockets. Use them.
Feedback
RatFink is offline   Reply With Quote
Old 05-03-2013, 12:05 AM   #2 (permalink)
All hail RatFink!
 
RatFink's Avatar
 
Join Date: Jan 2008
Location: Ronapour

Well, I took out the empire valve and went back to the stock valve with the Eigen ram and it basically had the same problem with low inconstant velocity, but at least it didn't leak. I swapped the noid for a brand new one I had sitting in my spares and I was able to get it to 280 fps and it was more consistent, like within 3fps, but at random it will still drop, or shoot hot and it still seems like the LPR is set higher than I wouldilike. My only thought now is the ShockTec bolt is the problem, but I don't really have a lot of experience with the Timmy's, so any advice is appreciated.
__________________
Quote:
Originally Posted by Wraith View Post
If you can't be bothered to pick up your 12 grams, you don't deserve to be playing on a field. You have pockets. Use them.
Feedback
RatFink is offline   Reply With Quote
Old 05-04-2013, 07:53 PM   #3 (permalink)
wookie in a mask
 
p8ntballr68059's Avatar
 
Join Date: Aug 2009
Location: Cornandcowville
Send a message via Yahoo to p8ntballr68059

Palmers Fan
reset board to stock settings. change all orings in lpr and hpr making sure lubed properly. i would also change the ram orings. the eigen ram could be the cause also. my alias hated the eigen but the infamous loved it.

i would just reset all to stock settings and start from there
__________________
Agglets are but a stain on the paintball community
vicous fan 42
NEBRASKA BALLAS PM ME IM LOOKING FOR A TEAM

p8ntballr68059 is offline   Reply With Quote
Old 05-04-2013, 08:06 PM   #4 (permalink)
Woodsball Connoisseur
 
Grendal50's Avatar
 
Join Date: Jul 2008

Fan of EMR
Brass N Wood Fan
Palmers Fan
Also see if the shocktec bolt cycles smooth, I have one that the back half was not straight with the front.
__________________
"Some people say that I must be a terrible person, but it's not true. I have the heart of a young boy in a jar on my desk." -Stephen King
Feedback Want to buy Pump sale Electronic Sale Misc Sale Moar Guns!
Steam tag: Grendal50
Xbox live: Grendal50
Grendal50 is offline   Reply With Quote
Old 05-05-2013, 01:32 PM   #5 (permalink)
All hail RatFink!
 
RatFink's Avatar
 
Join Date: Jan 2008
Location: Ronapour

Thanks for the tips guys. The bolt doesn't stick, but I wouldn't say it's "free" either. The board is set to stock. I have tried both a factory ram as well as the Egin and they both act the same. I even put new O rings on the rams. It's not bad now, I just think this thing should be able to run a little better than it is right now. I'm thinking about trying the Black Spyder spring mod to see if it runs more consistently and if I can drop the LPR back down some.
__________________
Quote:
Originally Posted by Wraith View Post
If you can't be bothered to pick up your 12 grams, you don't deserve to be playing on a field. You have pockets. Use them.
Feedback
RatFink is offline   Reply With Quote
Old 05-09-2013, 10:52 PM   #6 (permalink)
wookie in a mask
 
p8ntballr68059's Avatar
 
Join Date: Aug 2009
Location: Cornandcowville
Send a message via Yahoo to p8ntballr68059

Palmers Fan
how new is the eigen ram sometimes they will take a break in time. i would change he bolt and see where that goes on this. i would also sweet spot the hpr and adjust velocity via lpr
__________________
Agglets are but a stain on the paintball community
vicous fan 42
NEBRASKA BALLAS PM ME IM LOOKING FOR A TEAM

p8ntballr68059 is offline   Reply With Quote
Old 05-14-2013, 06:51 PM   #7 (permalink)
MCB Member
 
Spider!'s Avatar
 
Join Date: Dec 2008
Location: Houston, TX

It has been a while since I've had mine apart.

If the square cross section seal on the lpr gets messed up, can the HPR air leak into the LPR output?

I discovered that my well used solenoid likes very light oil and refuses to work with grease. It doesn't work with superlube with teflon, but superlube air tool oil or similar light oils are good.

One of its original problems was that the battery wiring harness connection had a bad wire where it went into the connector. It had enough power to run the board, but it often had trouble firing.

Be careful with the barbs.
__________________
My Feedback
Spider! is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Bob Long

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 01:17 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC