mcarterbrown.com  

CCI Home of the Phantom Pump Gun

Reply
 
Thread Tools Search this Thread
Old 06-05-2012, 07:39 PM   #1 (permalink)
Newbie
 
Join Date: Jun 2012

Help with Rainman Pump Kit?

Posted on TechPB but i figured i might get more replies here, I bought a huge package of phantom parts for a great deal of ebay, anyway along with the parts came a Rainman UC kit that appeared to work fine.

However, when i went out with it, i noticed something, the thing comes lose constantly.... like if i dont tighten it down after every game its going to fall off loose. When i asked people if they experienced this problem most replied no, and i have yet to find a bad review of the rainman kit, so i would assume this is a flaw.

So my question, Has anyone else had this problem? If so how did you fix it, or what can i do?

I have a few ideas of what it might be, the first being that the screw is too short, and doesent thread into the body fully (because the body comes lose as well as the kit). Maybe the Screw or threads in the body are stripped or damaged?
IVIidnight is offline   Reply With Quote
Old 06-05-2012, 11:35 PM   #2 (permalink)
Stock class SPAM
 
808Jackal's Avatar
 
Join Date: Apr 2010
Location: Honolulu, HI

Try drop a small O ring on the screw? I've had mine come loose after a half day. It used to happen with the old phantom thumbscrews back in the day too. That's why they have orings on them now.
808Jackal is offline   Reply With Quote
Old 06-05-2012, 11:41 PM   #3 (permalink)
Rec Poster
 
Join Date: Sep 2009

I've put a locking washer on mine. The first time the screw loosened up on me was when I AT'd. Ended up losing the screw. Using an 8-32 x 3/4 screw now
xixeyexix is offline   Reply With Quote
Old 06-05-2012, 11:42 PM   #4 (permalink)
The Man With No Plan
 
super_stanchy's Avatar
 
Join Date: Nov 2008
Location: Oregon City, OR

CCM Fan
PBN Fan
use some loctite... use the blue stuff..... easy
super_stanchy is offline   Reply With Quote
Old 06-05-2012, 11:44 PM   #5 (permalink)
Newbie
 
Join Date: Jun 2012

Ill try an o-ring, and need to get my hands on some more loctite, thanks for the help guys, ill update if it is fixed if not the measurements up there will help ^^
IVIidnight is offline   Reply With Quote
Old 06-06-2012, 12:48 AM   #6 (permalink)
Active Member
 
BassDude's Avatar
 
Join Date: Apr 2011

3/4 was too long for mine. I went with a 8-32 x 5/8 (same as the feedtube screw). Anyways, I have a lock washer on mine and it doesn't move.
BassDude is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » CCI

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 04:17 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC