mcarterbrown.com

mcarterbrown.com (http://www.mcarterbrown.com/forums/)
-   CCI (http://www.mcarterbrown.com/forums/cci/)
-   -   Phantom CCI undercocking kit problem. (http://www.mcarterbrown.com/forums/cci/210957-phantom-cci-undercocking-kit-problem.html)

Aw1195 08-14-2012 09:18 PM

Phantom CCI undercocking kit problem.
 
Hi fellow MCB,

I recently purchase a phantom with a CCI undercocking pump kit and every cock with air (HPA) the pump handle will stay in place, not finishing the complete "maneuver" of cocking back and then automatically pushing the pump handle back into the original position where I can just pump and then shoot. Anyone know how to fix this problem?

Thanks,
Aw1195

CxT 08-14-2012 09:21 PM

Quote:

Originally Posted by Aw1195 (Post 2444110)
Hi fellow MCB,

I recently purchase a phantom with a CCI undercocking pump kit and every cock with air (HPA) the pump handle will stay in place, not finishing the complete "maneuver" of cocking back and then automatically pushing the pump handle back into the original position where I can just pump and then shoot. Anyone know how to fix this problem?

Thanks,
Aw1195

Just to be sure, you installed the pump return spring?

There should be a long spring that goes on the cocking rod, and a small partial white washer that keeps the spring from binding in the body. If the washer isn't there, its likely the spring has nothing to push against and is actually moving inside the body rather than providing return force.

If this is a problem only with HPA, that does seem a bit on the odd side..

Legolas 08-14-2012 09:37 PM

also check to see if the pump rod is threaded all the way into the pump handle:
if yes, unscrew it until it is threaded with half of the threads showing.
check the alignment of the pump rod and the bolt--if these are off slightly it can cause binding.

Aw1195 08-14-2012 09:42 PM

Okay, I see the problem now, there isnt a pump return spring. Is there a place where I can just purchase the pump return spring only for the CCI undercocking pump kit?

Aw1195 08-14-2012 09:44 PM

Legolas - No, there is some thread showing on the pump handle, and the alignment of the pump rod is attached the the bolt.

CxT 08-14-2012 11:08 PM

You should be able to use the one on your standard pump... I'm not entirely sure about that one though, since I never had the original pump handle (I got mine with undercocking from factory)

Aw1195 08-14-2012 11:13 PM

I ghetto made a return spring, ill upload a pic to see if it corresponds correctly to what you were talking about.

Aw1195 08-14-2012 11:18 PM

1 Attachment(s)
Attachment 34548

fauxmulder 08-14-2012 11:55 PM

Quote:

Originally Posted by Aw1195 (Post 2444143)
Okay, I see the problem now, there isnt a pump return spring. Is there a place where I can just purchase the pump return spring only for the CCI undercocking pump kit?

Call Mike at CCI and order a pump return spring. It's the same spring as factory, and it goes on the cocking arm... I see what you did there, but you need the spring for the cocking arm.

uNrattedd 08-15-2012 01:23 AM

you don't need the return spring on the pump/bolt rod. a return spring does it's job as long as the pump handle/bolt returns to it's forward position through spring action. having the spring on the UC kit pump guide is just fine if the spring has enough tension to return the bolt full forward.

or if you prefer to order one straight from CCI, i believe mike charges $2 for a return spring; however i might not be correct on that


All times are GMT -4. The time now is 04:16 AM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC