mcarterbrown.com
 

CCI Home of the Phantom Pump Gun

Reply
 
Thread Tools Search this Thread
Old 02-15-2013, 12:02 PM   #1 (permalink)
Doesn't care (/◕ヮ◕)/
 
JLuke's Avatar
 
Join Date: Oct 2010
Location: Lafayette, La

CCM Fan
AKA Fan
weird pump stroke at back of pump motion.

Currenly have a phantom that has a a problem with the back stroke on the pump, pulling the pump back is normal, but to get the hammer to catch on the sear you have to pull very hard for the last 1/4 of an inch of the stroke for it to catch, i've pulled the thing apart and lubed it and checked for binding and everything looks ok. Any chance it could be sprung wrong or need new springs?
__________________
Feedback


I don't always play pump, but when I do, I prefer a rotor.....stay agg my friends.
JLuke is offline   Reply With Quote
Old 02-15-2013, 12:07 PM   #2 (permalink)
MCB Member
 
capitalpaintball's Avatar
 
Join Date: Jul 2006
Location: Coventry R.I.

I am assume you have air on the marker when pumping it.
It could be to light a valve spring or to heavy a main spring, But first I would check that the velocity screw adjuster inst screwed to far in.
capitalpaintball is offline   Reply With Quote
Old 02-15-2013, 02:01 PM   #3 (permalink)
Doesn't care (/◕ヮ◕)/
 
JLuke's Avatar
 
Join Date: Oct 2010
Location: Lafayette, La

CCM Fan
AKA Fan
Thanks, i'll give that a check.
__________________
Feedback


I don't always play pump, but when I do, I prefer a rotor.....stay agg my friends.
JLuke is offline   Reply With Quote
Old 02-15-2013, 08:14 PM   #4 (permalink)
Active Member
 
StockClassPunk's Avatar
 
Join Date: Jan 2013
Location: Canada Eh

CCM Fan
AKA Fan
Palmers Fan
my guesses are this.
1. Main spring is too stiff
and/or
2. the hammer has a spring in it and maybe that is too worn down?
and/or
3. the hammer itself may be worn down.
StockClassPunk is offline   Reply With Quote
Old 02-16-2013, 04:24 AM   #5 (permalink)
Doesn't care (/◕ヮ◕)/
 
JLuke's Avatar
 
Join Date: Oct 2010
Location: Lafayette, La

CCM Fan
AKA Fan
Welp i got it fixed. come to find out the bend in the pump arm below where it goes into the bolt was hitting a pin in that pump arm slot i assume that is there to stop the pump arm, it looks like it has no other use. i ground down the pump arm bend a few fractions and it pumps smooth as can be now.


It just seems odd though, on my old phantom it was nowhere near hitting, and on this one it hit the back, not sure if that was a from the factory problem or something that came up over the years.
__________________
Feedback


I don't always play pump, but when I do, I prefer a rotor.....stay agg my friends.
JLuke is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » CCI

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 12:38 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC