mcarterbrown.com
 

CCI Home of the Phantom Pump Gun

Reply
 
Thread Tools Search this Thread
Old 06-18-2013, 02:11 AM   #1 (permalink)
MCB Member
 
Sideburns's Avatar
 
Join Date: Mar 2012
Location: Hjaernarp,Sweden

AKA Fan
Phantom consistency trouble- Need help!

Bought my first Phantom for a while ago...
I run it on 12g.

It acts REALLY strange:

First shot: 320 fps
Second: 270
Third: 240
Fourth:210

-and so on.
A 12 g is enough for like 8-10 shots....

No leaks.

I opened it up yesterday, cleaned it up and checked all parts.

Found this rubber thingy, doesn´t seem to belong?








.
__________________
Sideburns is offline   Reply With Quote
Old 06-18-2013, 02:49 AM   #2 (permalink)
Stock class SPAM
 
808Jackal's Avatar
 
Join Date: Apr 2010
Location: Honolulu, HI

Yeah that does not belong at all...

Also check to see if the powertube is screwed all the way into the cup seal.
808Jackal is offline   Reply With Quote
Old 06-18-2013, 02:51 AM   #3 (permalink)
MCB Member
 
Sideburns's Avatar
 
Join Date: Mar 2012
Location: Hjaernarp,Sweden

AKA Fan
Quote:
Originally Posted by 808Jackal View Post
Yeah that does not belong at all...

Also check to see if the powertube is screwed all the way into the cup seal.
Yeah,powertube seems a ok.

The rubber thingy seems to be some kind of ghetto mod....
Should i get rid of it?



.
__________________
Sideburns is offline   Reply With Quote
Old 06-18-2013, 08:42 AM   #4 (permalink)
No class
 
RatFink's Avatar
 
Join Date: Jan 2008
Location: Ronapour

Yeah, loose that thing for sure. where it is, the main hammer spring seats. Makes me wonder if someone clipped the hammer spring and tried to make up for it with a rubber spacer?
I had some consistency issues not too long ago and it turned out to be I was getting half roll outs. I threw some nail polish in the barrel and it has been fine since.
__________________
Quote:
Originally Posted by HurtCow View Post
Because brass.
Quote:
Originally Posted by russc View Post
I'm like a paintball sex tourist. Top dollar for a good time.
Feedback
RatFink is offline   Reply With Quote
Old 06-18-2013, 08:51 AM   #5 (permalink)
Village Idiot
 
Greenmtnphantom's Avatar
 
Join Date: Jul 2006
Location: Graniteville VT
Send a message via AIM to Greenmtnphantom Send a message via MSN to Greenmtnphantom

Fan of EMR
Get rid of the rubber.

Check for partial Rollouts.

Check to be sure that your TPC setscrew isn't loose.

Is it just the picture or is there damage to the face of the TPC?

What do you have for springs in this thing? Any DIY mods in the valve?
__________________
Feedback http://www.mcarterbrown.com/forums/f...-feedback.html Gargoyle FAQ http://isppa.semkhor.com/newswire.asp?ctid=1116
Quote:
Originally Posted by Robertsr View Post
I don't so much make money, as provide a conduit for it's movement.
Stock class = 12grams and a stick feed. End discussion.
Greenmtnphantom is offline   Reply With Quote
Old 06-18-2013, 09:05 AM   #6 (permalink)
Active Member
 
darkspidie1984's Avatar
 
Join Date: Nov 2008
Location: Melbourne, florida

Quote:
Originally Posted by Greenmtnphantom View Post
Get rid of the rubber.

Check for partial Rollouts.
This is a really common one. Especially if your using stock barrel. Today's paint is so small I have no idea what companies still make barrel with greater than about .687. I use a freaked stock barrel with a .679 insert. It solved all my velocity problems.
darkspidie1984 is offline   Reply With Quote
Old 06-18-2013, 09:35 AM   #7 (permalink)
MCB Member
 
Sideburns's Avatar
 
Join Date: Mar 2012
Location: Hjaernarp,Sweden

AKA Fan
Get rid of the rubber. Will do,sir.

Check for partial Rollouts. Not the problem here,as i shot from my basement stairs and out- upwards the sky...

Check to be sure that your TPC setscrew isn't loose. It IS really loose,but doesn´t seem to be any way to tighten it?

Is it just the picture or is there damage to the face of the TPC? Yeah,small damage in the face,where the tool connects.

What do you have for springs in this thing? Any DIY mods in the valve?
None that i know of. Stock silver spring,have tested the red one with same result.
__________________
Sideburns is offline   Reply With Quote
Old 06-18-2013, 09:59 AM   #8 (permalink)
Village Idiot
 
Greenmtnphantom's Avatar
 
Join Date: Jul 2006
Location: Graniteville VT
Send a message via AIM to Greenmtnphantom Send a message via MSN to Greenmtnphantom

Fan of EMR
Quote:
Originally Posted by Sideburns View Post
Get rid of the rubber. Will do,sir.

Check for partial Rollouts. Not the problem here,as i shot from my basement stairs and out- upwards the sky...

Check to be sure that your TPC setscrew isn't loose. It IS really loose,but doesn´t seem to be any way to tighten it?

Is it just the picture or is there damage to the face of the TPC? Yeah,small damage in the face,where the tool connects.

What do you have for springs in this thing? Any DIY mods in the valve?
None that i know of. Stock silver spring,have tested the red one with same result.
The side of bolt should have a nylon set screw in it. Remove the TPC, Tighten that set screw a little bit to provide friction on the TPC when you put it back in.

Paint to barrel match could still be a problem. If the paint is smaller than the barrel it's not sealing well and allowing a lot of air to be wasted blowing by the ball instead of pushing it.

Starting at 320 you are using a lot of air to begin with. See if you can get it down to a first shot of about 270, thats where I try to put mine, some go higher, some lower.

Once you get rid of that rubber piece and get the TPC tightened up (should have some resistance when you use the velocity tool but not be difficult, you just don't want it moving freely) let us know how that changes things. I think you will see a major change with those two things fixed.
__________________
Feedback http://www.mcarterbrown.com/forums/f...-feedback.html Gargoyle FAQ http://isppa.semkhor.com/newswire.asp?ctid=1116
Quote:
Originally Posted by Robertsr View Post
I don't so much make money, as provide a conduit for it's movement.
Stock class = 12grams and a stick feed. End discussion.
Greenmtnphantom is offline   Reply With Quote
Old 06-18-2013, 10:11 AM   #9 (permalink)
MCB Member
 
Sideburns's Avatar
 
Join Date: Mar 2012
Location: Hjaernarp,Sweden

AKA Fan
Thanks.

There is no nylonscrew in the bolt, though.
Had the gun in pieces yesterday, and looked for it.
Might be a bolt switch, maybe?
__________________
Sideburns is offline   Reply With Quote
Old 06-18-2013, 10:21 AM   #10 (permalink)
Village Idiot
 
Greenmtnphantom's Avatar
 
Join Date: Jul 2006
Location: Graniteville VT
Send a message via AIM to Greenmtnphantom Send a message via MSN to Greenmtnphantom

Fan of EMR
Could be, is this a really old Phantom?

You might be able to use Teflon tape on the threads as a quick fix. CCI sells TPC's now with an Oring groove in the threads that gives it enough friction to stay in place. Thats likely what the rubber piece was meant to do.
__________________
Feedback http://www.mcarterbrown.com/forums/f...-feedback.html Gargoyle FAQ http://isppa.semkhor.com/newswire.asp?ctid=1116
Quote:
Originally Posted by Robertsr View Post
I don't so much make money, as provide a conduit for it's movement.
Stock class = 12grams and a stick feed. End discussion.
Greenmtnphantom is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » CCI

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 06:50 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC