mcarterbrown.com
 

CCM Chipley Machine

Reply
 
Thread Tools Search this Thread
Old 01-02-2011, 08:33 PM   #1 (permalink)
Seasoned Member
 
506guballer's Avatar
 
Join Date: May 2008
Location: 13.2 N / 144.6 E

J2 with cocking rod slipping or not gripping

Hello everyone. I recently picked up a used J2 that is in almost perfect condition. I noticed the other day when I played with it for the first time that sometimes the cocking rod would slip?/get stuck when I pump and I either pumped again or pushed the rod forward for it to fire. It feels like the rod is not gripping if that's the correct way to describe it. It happened enough times on the field to be annoying. I watched TF's video on setting the timing on the AT and I think that helped a lot but without paint I can't really be for certain. If it still happens any suggestion?

Also Mel does CCM have in stock screws that connect the grip frame to the body? I discovered that one of the screws was actually a tad short and I've been unsuccessful in finding the right length at Home Depot or the hardware stores.
__________________
M.Carter Brown Feedback:
http://www.mcarterbrown.com/forums/f...tml#post633890
PBNation Feedback:
http://www.pbnation.com/feedback.php?u=383004
506guballer is offline   Reply With Quote
Old 01-02-2011, 09:02 PM   #2 (permalink)
Hawkeye: Finest Kind
 
Marathon's Avatar
 
Join Date: Nov 2009
Location: Suburbs of Toronto

CCM Fan
Do you have both frame screws installed? I usually have to use longer screws with a washer or two to get things to fit.
If you don't have a frame screw in this may explain the problem. Is the cocking rod/hammer not catching on the sear when you pump back OR is the hammer not releasing from the sear when pull the trigger?
JC
__________________
Feedback
M.CarterBrown
Custom Cockers
Marathon is offline   Reply With Quote
Old 01-02-2011, 09:08 PM   #3 (permalink)
"Set The Bar Low"
 
Whiskey's Avatar
 
Join Date: Oct 2009
Location: cleveland, ohio

CCM Fan
the screws are suposed to be 2 different lengths, long in the front short in the back. If you have the long screw in the back it is catching the hammer when you cock the marker. You may have to pull the hammer out and give it a good polishing.
__________________
MY FEEDBACK @ MCB
http://www.mcarterbrown.com/forums/f...eedback-2.html
70+ 0-

MY FEEDBACK ON EBAY
http://myworld.ebay.com/ebwilsonx4


A long time ago I met a Man I called my friend. Why now, many years later, can't I remember his face? Has He left, or have I just chose not to look?
Whiskey is offline   Reply With Quote
Old 01-02-2011, 09:38 PM   #4 (permalink)
Newbie++
 
noclue119's Avatar
 
Join Date: Apr 2009
Location: Atlanta, GA

CCM Fan
are you sure your hammer lug is far enough down?
__________________
"Originally posted by Element Paintball@pbnation: you realize it would be easier to get a new wife than a new dc2."



My MCB Feedback
noclue119 is offline   Reply With Quote
Old 01-02-2011, 10:42 PM   #5 (permalink)
Seasoned Member
 
506guballer's Avatar
 
Join Date: May 2008
Location: 13.2 N / 144.6 E

Quote:
Originally Posted by JayC262 View Post
Do you have both frame screws installed? I usually have to use longer screws with a washer or two to get things to fit.
If you don't have a frame screw in this may explain the problem. Is the cocking rod/hammer not catching on the sear when you pump back OR is the hammer not releasing from the sear when pull the trigger?
JC
yup both frame screws were installed when I encountered the problem.

The hammer is not releasing from the sear when I pull the trigger. The weird thing is it works fine when I'm dry firing but it happens when I have paint. Not sure why.

Quote:
Originally Posted by Whiskey View Post
the screws are suposed to be 2 different lengths, long in the front short in the back. If you have the long screw in the back it is catching the hammer when you cock the marker. You may have to pull the hammer out and give it a good polishing.
the long screw was in the front and the short screw was in the rear....the short screw just didn't look long enough but I'll double check again to make sure....

Quote:
Originally Posted by noclue119 View Post
are you sure your hammer lug is far enough down?
the lug definitely needed adjustment when I was playing..I was able to adjust it last night after watching TF's video so I'm hoping that solved the problem
__________________
M.Carter Brown Feedback:
http://www.mcarterbrown.com/forums/f...tml#post633890
PBNation Feedback:
http://www.pbnation.com/feedback.php?u=383004
506guballer is offline   Reply With Quote
Old 01-03-2011, 05:20 AM   #6 (permalink)
Seasoned Member
 
506guballer's Avatar
 
Join Date: May 2008
Location: 13.2 N / 144.6 E

Checked the screws and yep the all screw is a little short....

I also got some paint and fired a hopper....it seems to fire okay except when I pump it and let go of the pump arm...then something weird occurs but I need to do a video to explain it....I have a feeling I installed the AT wrong....AT works though...is there like a diagram on how to put the AT back correctly?
__________________
M.Carter Brown Feedback:
http://www.mcarterbrown.com/forums/f...tml#post633890
PBNation Feedback:
http://www.pbnation.com/feedback.php?u=383004
506guballer is offline   Reply With Quote
Old 01-03-2011, 12:01 PM   #7 (permalink)
MCB Member
 
CCM CHICK's Avatar
 
Join Date: Sep 2007
Location: Far- Nor-Cal

CCM Fan
Give us a call and we’ll be more than happy to see what we can do to get you squared away.
~M
__________________
I will be more than happy to answer any CCM related questions, just give me a call!
CCM: 1-877-412-6850
melissa@chipleymachine.com


Quote:
Originally Posted by Bored383 View Post
I don't care what anyone uses to play - just don't be a douche to your fellow players. Its the golden rule.
CCM CHICK is offline   Reply With Quote
Old 01-03-2011, 05:57 PM   #8 (permalink)
Seasoned Member
 
506guballer's Avatar
 
Join Date: May 2008
Location: 13.2 N / 144.6 E

Thanks Mel, will do as soon as I can given the time differences.
__________________
M.Carter Brown Feedback:
http://www.mcarterbrown.com/forums/f...tml#post633890
PBNation Feedback:
http://www.pbnation.com/feedback.php?u=383004
506guballer is offline   Reply With Quote
Old 01-05-2011, 07:29 PM   #9 (permalink)
Seasoned Member
 
506guballer's Avatar
 
Join Date: May 2008
Location: 13.2 N / 144.6 E

Just a little update..I found some screws at a home center....not silver like my J2 but black will do.

Mel I'll try to give you a call on Friday afternoon which is like Saturday morning for me.
__________________
M.Carter Brown Feedback:
http://www.mcarterbrown.com/forums/f...tml#post633890
PBNation Feedback:
http://www.pbnation.com/feedback.php?u=383004
506guballer is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » CCM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 01:20 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC