mcarterbrown.com  

CCM Chipley Machine

Reply
 
Thread Tools Search this Thread
Old 07-20-2012, 05:26 PM   #1 (permalink)
Active Member
 
DevilMayCare's Avatar
 
Join Date: Jun 2012
Location: Dallas, TX

T2 trigger pull problem

Something is up with the trigger pull on my T2. It was fine last weekend, then after cleaning this week I noticed a change.

I have to pull the trigger all the way back then give it a little more pressure before it fires.

When I cleaned it I took the pump off, removed the back-block, bolt pin and bolt. I also removed the grip panels to give them a good scrub.

I wiped everything down with the mix of detergent, alcohol and water that Tal recommends, ran a swab down the barrel and through the top tube, then dried everything thoroughly and re-assembled.

The only other thing I did was to try an remove the bolt for the auto-trigger (before I reviewed Tal's video and saw that I didn't need to do so.) The bolt on mine is stripped out a bit (bought this marker used about a month ago) and I put a good bit of pressure on it trying to get it off, before giving up and checking the video.

Any thoughts on what might be wrong, or where I should start? We're playing Sunday and I'm hoping to resolve this before then
DevilMayCare is offline   Reply With Quote
Old 07-20-2012, 06:04 PM   #2 (permalink)
Formerly lancecst
 
BLachance75's Avatar
 
Join Date: Sep 2006
Location: Western Mass

CCM Fan
Try adjusting the hammer lug.
__________________
BLachance75 is offline   Reply With Quote
Old 07-20-2012, 06:06 PM   #3 (permalink)
MCB Member
 
CCM CHICK's Avatar
 
Join Date: Sep 2007
Location: Far- Nor-Cal

CCM Fan
Quote:
Originally Posted by DevilMayCare View Post
Something is up with the trigger pull on my T2. It was fine last weekend, then after cleaning this week I noticed a change.

I have to pull the trigger all the way back then give it a little more pressure before it fires.

When I cleaned it I took the pump off, removed the back-block, bolt pin and bolt. I also removed the grip panels to give them a good scrub.

I wiped everything down with the mix of detergent, alcohol and water that Tal recommends, ran a swab down the barrel and through the top tube, then dried everything thoroughly and re-assembled.

The only other thing I did was to try an remove the bolt for the auto-trigger (before I reviewed Tal's video and saw that I didn't need to do so.) The bolt on mine is stripped out a bit (bought this marker used about a month ago) and I put a good bit of pressure on it trying to get it off, before giving up and checking the video.

Any thoughts on what might be wrong, or where I should start? We're playing Sunday and I'm hoping to resolve this before then
Rod will be in the shop for the next 25 mins. Call him!
1-877-412-6850
__________________
I will be more than happy to answer any CCM related questions, just give me a call!
CCM: 1-877-412-6850
melissa@chipleymachine.com


Quote:
Originally Posted by Bored383 View Post
I don't care what anyone uses to play - just don't be a douche to your fellow players. Its the golden rule.
CCM CHICK is offline   Reply With Quote
Old 07-20-2012, 07:43 PM   #4 (permalink)
The cries of the carrots
 
Hogzilla88's Avatar
 
Join Date: May 2011
Location: Arlington, Tx

CCM Fan
raise your lug a bit.
Hogzilla88 is offline   Reply With Quote
Old 07-20-2012, 09:00 PM   #5 (permalink)
Active Member
 
DevilMayCare's Avatar
 
Join Date: Jun 2012
Location: Dallas, TX

Raised the lug and things seem back to normal. If it doesn't feel 100% this weekend I'll give Rod a call on Monday. Thanks all!
DevilMayCare is offline   Reply With Quote
Old 07-22-2012, 09:48 AM   #6 (permalink)
Red
 
Talfuchre's Avatar
 
Join Date: May 2006

CCM Fan
Happens to me during reassembly a lot too. It was your lug. Don't sweat it...

TF
__________________
Pumpenstein - NSA National Champions

TF's MCB Trust.
Talfuchre is offline   Reply With Quote
Old 07-22-2012, 06:30 PM   #7 (permalink)
Active Member
 
DevilMayCare's Avatar
 
Join Date: Jun 2012
Location: Dallas, TX

Yep, she shot like a champ all day after a small adjustment to the lug. I was really happy with this marker today, she shot so smooth, consistent and I was blowing up masks all day. I was running my R7 and will try to get some video up this week.
DevilMayCare is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » CCM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 06:58 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC