mcarterbrown.com

mcarterbrown.com (http://www.mcarterbrown.com/forums/)
-   CCM (http://www.mcarterbrown.com/forums/ccm/)
-   -   Fist Time Sniper Owner Looking for Help Tuning an S6 (http://www.mcarterbrown.com/forums/ccm/211477-fist-time-sniper-owner-looking-help-tuning-s6.html)

sQuidvision 08-21-2012 01:06 AM

Fist Time Sniper Owner Looking for Help Tuning an S6
 
So i just got my hands on a used S6 and while working over the marker i noticed that the pump rod doesnt snug into the guide plate when hole for the auto trigger is in the correct position. If i do snug it in the hole ends up vertical.

This wouldnt be an issue but the pump handle feels loose and sloppy when the pump rod isnt snug.

Whats the best course of action here? i was considering buying an EZ grip anyhow... would you expect that to fix it?

Forgive my noobness... im an automag guy in a cocker world!

Talfuchre 08-21-2012 09:04 AM

What's an automag? ;)


Pics would help - you may just have a bent pump rod - but I can't picture what you are saying.

TF

CCMachinist 08-21-2012 09:33 AM

Quote:

Originally Posted by sQuidvision (Post 2450202)
So i just got my hands on a used S6 and while working over the marker i noticed that the pump rod doesnt snug into the guide plate when hole for the auto trigger is in the correct position. If i do snug it in the hole ends up vertical.

This wouldnt be an issue but the pump handle feels loose and sloppy when the pump rod isnt snug.

Whats the best course of action here? i was considering buying an EZ grip anyhow... would you expect that to fix it?

Forgive my noobness... im an automag guy in a cocker world!

Stick a small allen key into the hole in the pump rod and tighten up the rod till it is in the correct position. Don't forget the red loctite on that thread.

It is best to take it off the gun while you tighten the rod in the pump plate.

Tighten it up where you think it is straight then slide the the pump handle on the guide rods and see where the hole lines up. You can use the screw to see if the hole is in the correct position.

sQuidvision 08-21-2012 01:34 PM

Quote:

Originally Posted by Talfuchre (Post 2450349)
What's an automag? ;)

:censored: lol

@CCM - Thanks! I thought i had read about people breaking their pump rods so i was hesitant to apply the force needed to do what you suggested. I just tightened it up and it feels MUCH better.

Now i am having issues hitting velocity... i set the reg to 300 PSI and at about 3 turns in on the IVG the ball barely poops out the front of the barrel... im guessing i need a new spring. can anyone confirm this? Any suggestions on springs?

Thanks Gents!

CCM CHICK 08-21-2012 01:36 PM

Quote:

Originally Posted by sQuidvision (Post 2450598)
:censored: lol

@CCM - Thanks! I thought i had read about people breaking their pump rods so i was hesitant to apply the force needed to do what you suggested. I just tightened it up and it feels MUCH better.

Now i am having issues hitting velocity... i set the reg to 300 PSI and at about 3 turns in on the IVG the ball barely poops out the front of the barrel... im guessing i need a new spring. can anyone confirm this? Any suggestions on springs?

Thanks Gents!


Hi there!

Please feel free to call our tech Rod. He will be more than happy to help you out with your gun. He can be reached Mon-Thurs. 7am to 3:30pm PST.
1-877-412-6850

Thanks and I hope you have a good day!
~Mel @ CCM

sQuidvision 08-21-2012 01:43 PM

Awesome, Thanks Mel! you guys really are top notch with your customer service!

Toad 08-21-2012 02:23 PM

Quote:

Originally Posted by sQuidvision (Post 2450607)
Awesome, Thanks Mel! you guys really are top notch with your customer service!

QFT

brew52 08-21-2012 03:32 PM

Quote:

Originally Posted by Toad (Post 2450647)
QFT

Really?

Darring D 08-21-2012 04:44 PM

sQuidvision, make sure your bolt isn't in upside down!

sQuidvision 08-21-2012 05:30 PM

Quote:

Originally Posted by Darring D (Post 2450774)
sQuidvision, make sure your bolt isn't in upside down!

lol! yes, i did make sure that it was in the correct orientation. One thing i noticed is that it seems to make a "burb" noise when i shoot it... it also feels like air is escaping through the grip? I havent had a chance to call RoD yet... im sure once i do ill get pointed in the right direction.

Thanks!


All times are GMT -4. The time now is 05:29 PM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC