mcarterbrown.com

mcarterbrown.com (http://www.mcarterbrown.com/forums/)
-   CCM (http://www.mcarterbrown.com/forums/ccm/)
-   -   ASA install (http://www.mcarterbrown.com/forums/ccm/60587-asa-install.html)

Novster 12-19-2008 02:13 AM

ASA install
 
Hello everyone

My friend got a brand new ccm s6 in the mail not to long ago and hes having a bit of trouble getting the asa installed. The rail doesnt seem to "expand" as it should when the 2 screws are unscrewed.

Hes dying to use it and cant until he gets this blasted ASA installed.

Thanks

P.S does CCM not ship with manuals?

oggfueler 12-19-2008 02:15 AM

Turn harder... worked for me... and this was just today with my NEW S6.

oggfueler 12-19-2008 02:17 AM

To add to that... alternate tightening/turning between both screws.

Novster 12-19-2008 02:20 AM

hmm maybe were not installing this correctly :/ (hes sitting beside me with it)

Can someone write a detailed way to install, excuse our noobness :P

oggfueler 12-19-2008 02:34 AM

There's pretty much only one way to put it on aside from having the rail in the more forward or rearward position. If the rail is not expanding enough to hold the ASA in place then you need to just turn in the grubs that expand the rails. Look at the pic in the S6 manual in the sticky up at the top... it'll give you a hint on what the end product will/should look like.

Mel 12-19-2008 12:11 PM

Turn your screws clockwise once the rail is on the on/off where you want it placed. The more you turn, the more it will expand.
If your still having issues, give me a call.
~Mel @ CCM

fastev 12-19-2008 01:57 PM

The first time you install it it is really tight. Tighten one screw until it is snug, then the other. Keep going back and forth until the ASA stops moving.

oggfueler 12-19-2008 04:58 PM

Quote:

Originally Posted by fastev (Post 630100)
The first time you install it it is really tight. Tighten one screw until it is snug, then the other. Keep going back and forth until the ASA stops moving.

Bingo :thumbup:

Novster 12-20-2008 01:12 AM

it took ALOT of torquing but we have it attached!

If only i could afford one to :( i hate him right now :P

Thanks everyone

Talfuchre 12-21-2008 08:42 AM

I am glad you got it - I posted the same response on PHOG.

TF


All times are GMT -4. The time now is 03:36 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO
© MCB Network LLC