mcarterbrown.com  

Custom Projects / Custom Questions How do I customize? What do I customize? What do I use? Share you experiences and faults here!

Reply
 
Thread Tools Search this Thread
Old 02-25-2013, 04:36 AM   #1 (permalink)
MCB Member
 
scphantom9195's Avatar
 
Join Date: May 2006
Location: Hillsboro, OR

CCM Fan
Brass N Wood Fan
How do I directly wire and SP1 to a Rip Clip?

I found a wiring diagram on the BT forum (link here: Sign In - Warrior-Online) that showed how to wire a Rip Clip to a TM7. I tried to wire it to my SP1 as closely as possible, but since there are differences in the way the boards operate, it only partially works.

On full auto, I have to pull and release the trigger to get it to rotate. It seemed to work on semi auto ok though.

Can anyone help me figure it out?

Thanks.
__________________
"Only the strong survive. The weak are killed and eaten as fingerfood." SDI SSgt Patterson, USMC Platoon 1077

www.okcompanypaintball.com

http://www.mcarterbrown.com/forums/f...-feedback.html
scphantom9195 is offline   Reply With Quote
Old 02-25-2013, 09:10 AM   #2 (permalink)
Ask me about my
 
Skibbo's Avatar
 
Join Date: Oct 2009

FYI: Your link is to a sign in page, not the wiring diagram.

Seems like you're not getting a pulse out of the board on F/A like you do on S/A. Not sure how to do that with an SP1 though.
__________________
Quote:
Originally Posted by heinous View Post
i find this easy to masturbate to
Designer of the first legit looking ego pump, the EgoP!
BUY IT HERE!!


Tinkerer/ Pump lover
Team Akkadian Paintball Squad
OK D-Day '09 - German 716th IR
FEAR THE TREES!
Feedback:
http://www.mcarterbrown.com/forums/f...ml#post1067010
Skibbo is offline   Reply With Quote
Old 02-25-2013, 11:29 AM   #3 (permalink)
MCB Member
 
scphantom9195's Avatar
 
Join Date: May 2006
Location: Hillsboro, OR

CCM Fan
Brass N Wood Fan
Thanks, I think you might have to sign up on the forum to view the threads. Here it is:



Instructions from MondoMor:


Direct connection may work as well. Brainstorming:

Connect the grounds (-) of both boards together first. On the Rip Clip board, connect the ground close to the microphone. Then take one of the wires to the TM-7 solenoid (on the S+ testpoint of the TM-7 board) and connect it to the anode of a diode (cheap 1N4007 or so). The cathode of the diode should go through a 4.7k resistor to the clockwise-most terminal on a ~5k potentiometer. The anti-clockwise-most terminal should be connected to ground. The wiper of the pot should connect to the microphone's non-grounded lead through a 1k resistor.

The microphone may or may not need to be removed.

The pot will act as a volume control, dividing down the solenoid pulse to a lower voltage which may be more suitable for the microphone circuit. The diode keeps the negative-going pulse away from the Rip Clip board. The 1k resistor keeps some resistance between the microphone lead and ground, even when the pot is turned all the way down. The 4.7k resistor on the 5k pot makes sure the amplitude heading to the Rip Clip board won't be greater than about 4 volts.

To test, turn the "volume" control fully counter-clockwise and start shooting. Slowly turn up the volume until the board reacts to the shots. If it doesn't, try exchanging the 1k resistor between the pot wiper and board with a 470 ohm, then a 100 ohm. If it still doesn't work, some more sophisticated circuitry may be needed. It may even be necessary to flip the diode backwards, and use the negative-going solenoid pulse to fire the board.


I don't have a Rip Clip, or even a Reloader B board. I do have a board for a TSA that I'm repairing (another Empire/Kee sound-activated hopper), plus a spare TM-7 board. The sound activation may work differently, but I'm willing to give it a try.

-----------------------------------------------------------

Holy crap, it worked!

I can draw up a schematic, but the circuit I described above successfully triggered my TSA to feed every time the solenoid fired!

Instead of the potentiometer, I used a 10k resistor from the diode to the microphone, and a 1k resistor from the mic to ground. Sound activation no longer works, probably because of the 1k in parallel with the mic.

With a simple 1/8" jack and plug, this could be made removable, so the sound activation worked on the hopper when not plugged into the TM-7.

It's just like AGD's Intellifeed. Everything old is new again.

--------------------------------------------------------

I am not sure how the Rip Clip works, other than it picks up the noise when you fire your paintball gun. I am having trouble with the Rip Clip detecting the sound though.

I was hoping to be able to RF connect them, but the SP1 board does not have RF capability. I did find out that the Virtue board has RF though, and they are on sale right now, so I bought the Virtue board.

I would still like to know how to direct wire it though, if it can be done.

Thanks again.
__________________
"Only the strong survive. The weak are killed and eaten as fingerfood." SDI SSgt Patterson, USMC Platoon 1077

www.okcompanypaintball.com

http://www.mcarterbrown.com/forums/f...-feedback.html

Last edited by scphantom9195; 02-25-2013 at 11:33 AM.
scphantom9195 is offline   Reply With Quote
Old 02-25-2013, 02:38 PM   #4 (permalink)
MCB Member
 
Spider!'s Avatar
 
Join Date: Dec 2008
Location: Houston, TX

Quote:
Originally Posted by scphantom9195 View Post
-----------------------------------------------------------
Sound activation no longer works, probably because of the 1k in parallel with the mic.
--------------------------------------------------------

I am having trouble with the Rip Clip detecting the sound though.
Did you post the answer to your own problem?

Are you connected to the solenoid output or the switch input on your SP1?

If you are on the solenoid output on the SP1, then the pulses must be saturating the microphone circuit. You might need to go back to Mondo's original circuit with the potentiometer.

You could bump up the 10k resistor in increments to see if that works, which would be a safe process.

Can you try it at different rates of fire?
__________________
My Feedback
Spider! is online now   Reply With Quote
Old 02-25-2013, 04:48 PM   #5 (permalink)
MCB Member
 
scphantom9195's Avatar
 
Join Date: May 2006
Location: Hillsboro, OR

CCM Fan
Brass N Wood Fan
What I meant by the Rip Clip not picking up the shots is when it is firing. So I was wanting to direct wire it so that when the trigger is pulled, the Rip Clip rotates to feed the guns.

My set up is non-traditional, I have 2 SP1s mounted sideways and fed by the Rip Clips. It is a dual gun set up for my tank. I think because the Rip Clips are inside the turret and the barrels stick out is why they are not detecting the report.

I didn't try the pot method, I would have to go and buy a pot for testing. Thank you for the suggestion.

I did buy the Virtue boards and the RF chips, but I would still like to know how this could work. I am planning a second gun station built similar to this one, so if I can figure this out, I can save some cash on 2 more Virtue boards.

I will get a pot and see if I can get anything to work.

I have tried it connected to the 5v center trigger connection and from each of the outer trigger switch connections. Connecting the 5v to one of the other connections is what sorta works.

Then to just the outer trigger connections, which didn't work.

I hasve tried other various combinations to try and get it to work. I am glad that so far I haven't fried either board, lol.

Why can't the SP1 be connected the same as the TM7? It would be easy that way.
__________________
"Only the strong survive. The weak are killed and eaten as fingerfood." SDI SSgt Patterson, USMC Platoon 1077

www.okcompanypaintball.com

http://www.mcarterbrown.com/forums/f...-feedback.html
scphantom9195 is offline   Reply With Quote
Old 02-25-2013, 05:04 PM   #6 (permalink)
MCB Member
 
Spider!'s Avatar
 
Join Date: Dec 2008
Location: Houston, TX

Ah, yeah, the solenoid output would be the only output that pulses on every shot.

We had a discussion about bad sound pickups a while back. Something I've never needed to try is to put a support between the marker body and the loader, near the board. It would at least be informative to put an aluminum rod there to try to conduct the sound to the loader. When you get a quiet spool covered with a plastic body, the sound conduction to the plastic loader fizzles out.

Aluminum rod is not so bad compared to a pair of wires and components. Kind of like listening to a machine with a screw driver.

The mount may also be dampening things out too.
__________________
My Feedback

Last edited by Spider!; 02-25-2013 at 05:10 PM.
Spider! is online now   Reply With Quote
Old 02-25-2013, 05:58 PM   #7 (permalink)
MCB Member
 
scphantom9195's Avatar
 
Join Date: May 2006
Location: Hillsboro, OR

CCM Fan
Brass N Wood Fan
Interesting thoughts on the aluminum rod. I may try that. MondoMor also posted an idea about running a section of tubing from the muzzle into the Rip Clip body to help pick up the sound signature.

I am pretty sure that the RF will work, the Rip Clips are very close to the bodies. On the next gun system, they will be a little further away though.

Here is an older pic of the guns. They have changed a little but I have not taken recent pics.





The boards are relocated in the box between the ammo boxes.

Also when it's in the tank I have 14 or 16 inch CP barrels with Apex tips on them.
__________________
"Only the strong survive. The weak are killed and eaten as fingerfood." SDI SSgt Patterson, USMC Platoon 1077

www.okcompanypaintball.com

http://www.mcarterbrown.com/forums/f...-feedback.html
scphantom9195 is offline   Reply With Quote
Old 02-25-2013, 09:06 PM   #8 (permalink)
MCB Member
 
Join Date: Sep 2009

CCM Fan
Eddy, what about relocating the mics from the rip clip and/or using a different/more sensitive one?
__________________
Quote:
Originally Posted by storminnorman View Post
No one likes a dirty slot lol.
Quote:
Originally Posted by BigOldSkool View Post
I've played pump against the worst of the paintball scum bags, do I hang it up? Nah.... I play angrier.
Feedback: IonOwners.com PBNation old PBNation new AO MCB
B_i_s_c_u_i_t is offline   Reply With Quote
Old 02-26-2013, 12:11 AM   #9 (permalink)
MCB Member
 
scphantom9195's Avatar
 
Join Date: May 2006
Location: Hillsboro, OR

CCM Fan
Brass N Wood Fan
Quote:
Originally Posted by B_i_s_c_u_i_t View Post
Eddy, what about relocating the mics from the rip clip and/or using a different/more sensitive one?
I can't seem to find a more sensitive mic. FLASC used to sell them, but I guess BT has installed a new more sensitive mic from the factory now so FLASC discontinued thier mics. FLASC did set me on the right path in finding a mic though. FLASC actually sent me a link to mics that have wire leads on them. I could be possible to extend the wires to the Apex tips on the barrels and install them there. I could run the wire along the barrel. But that adds more wiring.

The RF option is expensive, but no more wires is actually appealing too. I just don't want to have to spend the extra cash if I don't have to.

I haven't actually worked on electronics in such I long time I am super rusty when it comes to figuring it all out. I was thinking that a pulsing circuit might be able to be built as well, but adds even more complications to it.
__________________
"Only the strong survive. The weak are killed and eaten as fingerfood." SDI SSgt Patterson, USMC Platoon 1077

www.okcompanypaintball.com

http://www.mcarterbrown.com/forums/f...-feedback.html
scphantom9195 is offline   Reply With Quote
Old 02-26-2013, 12:22 AM   #10 (permalink)
MCB Member
 
Join Date: Sep 2009

CCM Fan
I wonder if you could use a Magna board in the RC and then wire in the RF chips onto the SP1 boards.............IIRC ANS had Magna boards for super cheap

Check this page out Eddy: http://www.ansgear.com/Empire_Magna_...des_s/1143.htm
__________________
Quote:
Originally Posted by storminnorman View Post
No one likes a dirty slot lol.
Quote:
Originally Posted by BigOldSkool View Post
I've played pump against the worst of the paintball scum bags, do I hang it up? Nah.... I play angrier.
Feedback: IonOwners.com PBNation old PBNation new AO MCB
B_i_s_c_u_i_t is offline   Reply With Quote
Reply

  mcarterbrown.com » Custom » Custom Projects / Custom Questions

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 12:12 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC