mcarterbrown.com  

Reply
 
Thread Tools Search this Thread
Old 10-17-2013, 10:24 PM   #1 (permalink)
LeastGenericNicknameEver
 
Join Date: Apr 2013
Location: Southern Indiana

Ego7 worn out trigger switch?

So I'm trying to fix an ego 7 that has been sitting around my house for a couple years. It's my little brothers, but he never plays anymore, so I'm thinking "free ego". Only problem is I can't get the trigger to return. So I figured it was missing a trigger spring, but the ego 7 doesn't have one. Has anyone else ever had a micro switch wear out on a board? Is there another way I can get the trigger to return?
The Dawg is offline   Reply With Quote
Old 10-17-2013, 11:07 PM   #2 (permalink)
MCB Member
 
fullofpaint's Avatar
 
Join Date: Sep 2006
Location: Los Angeles, formerly Western MA

I'm too lazy to search but I believe the 07 has an opto switch not a microswitch. I know you could change between the two on some models, not sure which the 07 had.
fullofpaint is online now   Reply With Quote
Old 10-18-2013, 12:24 AM   #3 (permalink)
The Panda with a Gun
 
someasianballer's Avatar
 
Join Date: Nov 2009
Location: Richmond, Tx

CCM Fan
if ur trigger is not returning u need to make sure to clean off the pin also its a magnet return so make sure the set screw is there(top of the trigger closest to the back).

also it has both micro and opto
__________________
my feedback
someasianballer is offline   Reply With Quote
Old 10-23-2013, 11:58 PM   #4 (permalink)
Active Member
 
Join Date: Mar 2007
Location: Minnesota
Send a message via AIM to DriverJ

I believe the microswitch didn't show up until the 08 Ego, and was opto on the Ego7, sounds like you need to adjust the trigger return, clean the bearing and lube it lightly.
DriverJ is offline   Reply With Quote
Old 10-24-2013, 12:05 AM   #5 (permalink)
The Panda with a Gun
 
someasianballer's Avatar
 
Join Date: Nov 2009
Location: Richmond, Tx

CCM Fan
i have a stock 07 in my possession..it has both

but do what driver j suggested in regards to your trigger but i wouldnt put lube on it as it may get gummy later on which may cause some sticking
__________________
my feedback
someasianballer is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Eclipse

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 04:54 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC