mcarterbrown.com  

Empire Mini - Axe - Empire Sniper

Reply
 
Thread Tools Search this Thread
Old 02-11-2012, 01:58 PM   #1 (permalink)
Igloo member
 
Eskimo's Avatar
 
Join Date: Jun 2011
Location: Ontario Canada

Empire Sniper Fire hydrant Leak

FIXED! SEE below for Solution!

Hey guys, Got my Empire sniper. Air it up for the first time. Ait comes Blasting through the barrel.

Now you might be think

"LOL silly newb pull the pump handle back"

I can assure you I am literate, I'v read the manual. Even when you cock the marker then air it up. Air comes Rushing through the marker, its like I dont even have anything in the marker to stop the air. I'm losing like 500 PSI in a matter of seconds.

Any help? I'v pulled some of it apart. the O-rings look fine.

things which have been asked so far:
Bolt in Upside down - No
Cocking rod Pulled back before Airing - Yes
Reg Pressure - 225 PSI Pretty much on the dot
able to Fire without air - Yes
cup seal - Not cracked or broken

Noted that there was alot of Lube on the internals
Quote:
There's the problem! Lube on the cupseal makes it warp. Wipe it ALL off
wiped it off, cleaned it up a bit and airs up no leaks
Thanks guys!!
Especially Eddie for being a Champion.
You deserve lots of Good things in life!

Last edited by Eskimo; 02-11-2012 at 03:27 PM.
Eskimo is offline   Reply With Quote
Old 02-11-2012, 02:07 PM   #2 (permalink)
Facta Non Verba
 
Deuce's Avatar
 
Join Date: Jan 2009
Location: SCMO
Send a message via MSN to Deuce

Fan of EMR
CCM Fan
Is the bolt in upside down? Cocking rod pulled before airing?
__________________


Co-Captain/ Co-Founder
Team-Awesome

Quote:
Originally Posted by chopper duke View Post
I'd wipe, play-on and overshoot.
Deuce is offline   Reply With Quote
Old 02-11-2012, 02:15 PM   #3 (permalink)
Igloo member
 
Eskimo's Avatar
 
Join Date: Jun 2011
Location: Ontario Canada

You can actually put the bolt in Upside down?

Just pulled it out. The Hole on the Bolt is Pointed downwards. I can assure you.
Also. YES. As stated I'v pulled the cocking rod/Pumped it Back, and did not Fire. before I aired it up. as per manual instructions.
Eskimo is offline   Reply With Quote
Old 02-11-2012, 02:20 PM   #4 (permalink)
Bland
 
RAZRBAKK's Avatar
 
Join Date: Dec 2007
Location: Etobicoke, Ontario, Canada

What's the reg pressure sitting at?
RAZRBAKK is online now   Reply With Quote
Old 02-11-2012, 02:21 PM   #5 (permalink)
Igloo member
 
Eskimo's Avatar
 
Join Date: Jun 2011
Location: Ontario Canada

Pressure is Sitting at exactly 225 PSI...

This is While the air is gushing down the barrel.

1000 PSI left in HPA tank
Eskimo is offline   Reply With Quote
Old 02-11-2012, 02:27 PM   #6 (permalink)
Post Whore
 
Jinx's Avatar
 
Join Date: Jun 2009
Location: WMass

Is the hammer catching when there is no air?
__________________
Quote:
Originally Posted by Talfuchre View Post
I want to put a warning in here. If you, in any way, bad talk bacon or attempt to steer anyone away from bacon, or even hint about the ethics of bacon - I will perm ban you.
TF

Do not go gentle into that good night.
Rage, rage against the dying of the light.

Feedback
Jinx is offline   Reply With Quote
Old 02-11-2012, 02:28 PM   #7 (permalink)
Sector 2814
 
eddielives75's Avatar
 
Join Date: Oct 2011
Location: Camrose, Alberta

CCM Fan
Check your cup seal/poppit, if it's even in the gun at all
eddielives75 is offline   Reply With Quote
Old 02-11-2012, 02:31 PM   #8 (permalink)
Igloo member
 
Eskimo's Avatar
 
Join Date: Jun 2011
Location: Ontario Canada

By hammer catching you mean like I can pump and shoot it without air and it makes the audible clack

yes.

check cupseal / poppit.

thats a whole dis assembly eh... might as well
give me 15

Alright so Cupseal LOOKS fine. the only thing I can notice is it looks like a thin plastic is covering 1/2 the Rod which is glued into the plastic thingy...

Last edited by Eskimo; 02-11-2012 at 02:47 PM.
Eskimo is offline   Reply With Quote
Old 02-11-2012, 02:53 PM   #9 (permalink)
Igloo member
 
Eskimo's Avatar
 
Join Date: Jun 2011
Location: Ontario Canada

note: There is a METRIC TON of lube on the internals. like its almost Wet.
Eskimo is offline   Reply With Quote
Old 02-11-2012, 03:01 PM   #10 (permalink)
Sector 2814
 
eddielives75's Avatar
 
Join Date: Oct 2011
Location: Camrose, Alberta

CCM Fan
There's the problem! Lube on the cupseal makes it warp. Wipe it ALL off
eddielives75 is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Empire

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 07:31 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC