mcarterbrown.com  

Empire Mini - Axe - Empire Sniper

Reply
 
Thread Tools Search this Thread
Old 03-24-2013, 01:11 PM   #1 (permalink)
Rec Poster
 
Join Date: Nov 2010

Trracer leak

3-ish month old Trracer is leaking, seemingly out the barrel. I've tried just connecting the valve assembly to the tank and it leaks out the powertube.

Taking down the valve and rebuilding it seems to fix the leak until I fire a few shots - say 3-5, and then the leak comes back, and more severely with each shot.

I haven't owned a nelson valve gun before so I'm not sure what the cause is. I'm inclined to think either the face seal is worn (not likely after only 3 months surely?) or that on each shot the hammer is knocking the powertube loose from the face seal. If it's the latter case, should I loctite the powertube and face seal together? If not, what might it be?
/Drakk_ is offline   Reply With Quote
Old 04-10-2013, 01:23 AM   #2 (permalink)
Rec Poster
 
Join Date: Nov 2010

err...anybody? Is this in the wrong section?
/Drakk_ is offline   Reply With Quote
Old 04-29-2013, 08:38 PM   #3 (permalink)
Sector 2814
 
eddielives75's Avatar
 
Join Date: Oct 2011
Location: Camrose, Alberta

CCM Fan
Switch out the cupseal on the power tube
eddielives75 is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Empire

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 10:42 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO
© MCB Network LLC