mcarterbrown.com  

Reply
 
Thread Tools Search this Thread
Old 07-12-2011, 01:09 PM   #1 (permalink)
Evil Omen Techmaster
 
Join Date: Nov 2010

Xtra 04 valve placement and oring problem.

Ok, i havent used this gun in about a year so i ordered o-rings for it.
Ive taken it a part a billion times with no problems, but today, when i replaced the rings, it leaked through the valve. I have a tank oring followed by a regular black oring on the valve. Which end faces the lpr? The smaller end or the wider end? I placed the smaller end faceing me, but it leaked out a little. Do i need to get a red oring for the rear part of the valve?

Thanks for the help.
ogti9g9 is online now   Reply With Quote
Old 07-12-2011, 02:56 PM   #2 (permalink)
TANSTAAFL
 
Critical's Avatar
 
Join Date: Feb 2008
Location: People's Republic of Maryland

CCM Fan
The oring may not be sealing. You can get one of the red one's if you want, but I've always just used tank o-rings without a problem. Is the valve itself leaking, or is it the cupseal?
__________________
Running on an odd number of cylinders
Quote:
Originally Posted by jincay View Post
"WHY is that guy licking Criticals pants?"
My Feedback
Critical is offline   Reply With Quote
Old 07-13-2011, 05:11 PM   #3 (permalink)
Evil Omen Techmaster
 
Join Date: Nov 2010

I have replaced the cupseal, im pretty sure its just the orings.
ogti9g9 is online now   Reply With Quote
Old 07-18-2011, 05:52 PM   #4 (permalink)
Active Member
 
Join Date: Jan 2010

Look at your valve, the end with the smaller hole should go toward the hammer/striker. The end with the larger hole should go toward the LPR. Regular tank "o" rings should work for the valve itself, the black rubber one can be replaced with a nylon one. If the valve is oriented correctly and all of the seals have been replaced, but the valve is still leaking then you scratched the valve body during assembly/dis-assembly.
Mavalon is offline   Reply With Quote
Old 07-18-2011, 06:11 PM   #5 (permalink)
Evil Omen Techmaster
 
Join Date: Nov 2010

Aight, ive been putting the valve in reverse, thanks.
ogti9g9 is online now   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Kingman

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 02:47 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC