mcarterbrown.com  

Reply
 
Thread Tools Search this Thread
Old 04-09-2013, 09:18 PM   #1 (permalink)
Newbie
 
Join Date: Mar 2013

Hammer 7 Issues

So I just picked up a new Hammer 7 and out of the box I'm having some velocity and magazine issues. I couldn't get my velocity past 216 FPS, I have read that it might be a tank issue but I'm assuming that it's more of a main spring problem. I also was having mag feeding issues, when I was using 68 cal paint in it would double or even triple feed, but when I was using first strikes the magazines fed normally. Any helpful tips or tricks?
__________________
Let's just have a good time!
ghillieguy is offline   Reply With Quote
Old 04-10-2013, 06:27 AM   #2 (permalink)
Newbie
 
Join Date: Jul 2009

What is the output on the tank you were using? I tried using mine with compressed air and my output was under 600 PSI from my tank. I couldn't get the FPS past about 215, but once I put on CO2 and also used a tank with an output of 800 PSI the FPS went right up. As for the magazine feeding, I am having the same problem and have not figured it out yet. I think there is a thread on here or pbnation about the mag feeding issue, but I can't remember.
nowherekid109 is offline   Reply With Quote
Old 04-10-2013, 06:40 AM   #3 (permalink)
Post Whore
 
Join Date: Mar 2013
Location: Beantown, Kid!

Have you guys tried putting it in a trashcan?

Helped out with my problem. Granted, the marker still doesn't work, but I feel better about that now.
Frizzle Fry is offline   Reply With Quote
Old 04-10-2013, 07:18 AM   #4 (permalink)
MCB Member
 
1shot's Avatar
 
Join Date: Apr 2013
Location: MN

I feel like they just slapped the thing together and put it on the shelf without ever testing it. My old Hammer (from the 90's) is a rock solid K.I.S.S. pump machine. I don't know why they didn't keep the internals the same.
1shot is offline   Reply With Quote
Old 04-10-2013, 07:20 AM   #5 (permalink)
BAZINGA PUNK!!!
 
[MOOSE]'s Avatar
 
Join Date: Nov 2009
Location: Elko, NV
Send a message via Yahoo to [MOOSE]

Brass N Wood Fan
Quote:
Originally Posted by Frizzle Fry View Post
Have you guys tried putting it in a trashcan?

Helped out with my problem. Granted, the marker still doesn't work, but I feel better about that now.
If you're just gonna throw it away I'll pay shipping and you can give it to me.
__________________
By 2012 we thought we would have flying cars, all we have is blankets with sleeves.
You don't seem to understand, BRO. It's a Shotgun, that shoots Rockets, BRO!!!!!!
Feedback
Long distance member of: Team Long Stroke (It's like a long distance relationship only better)
[MOOSE] is offline   Reply With Quote
Old 04-10-2013, 05:23 PM   #6 (permalink)
Post Whore
 
Join Date: Mar 2013
Location: Beantown, Kid!

Quote:
Originally Posted by 1shot View Post
I feel like they just slapped the thing together and put it on the shelf without ever testing it. My old Hammer (from the 90's) is a rock solid K.I.S.S. pump machine. I don't know why they didn't keep the internals the same.
I'm thinking the same thing! I immediately went and found one of my handful of closet-dwelling Hammers in the hope that the valve seat was compatible - alas, it was not. Guess what though, the Hammer that lay untouched for a decade aired up fine!

If this had been done right...

The frame.
The valve seat.
The feedneck.
The magazine system.
Frizzle Fry is offline   Reply With Quote
Old 04-10-2013, 08:00 PM   #7 (permalink)
Rec Poster
 
Join Date: Feb 2013

the double feeding has to do with the detents
Seksirojo is offline   Reply With Quote
Old 04-11-2013, 12:04 AM   #8 (permalink)
Post Whore
 
danssoslow's Avatar
 
Join Date: Sep 2011

Quote:
Originally Posted by 1shot View Post
I feel like they just slapped the thing together and put it on the shelf without ever testing it. My old Hammer (from the 90's) is a rock solid K.I.S.S. pump machine. I don't know why they didn't keep the internals the same.
What kind of problems are you having with yours?
danssoslow is offline   Reply With Quote
Old 04-11-2013, 05:15 PM   #9 (permalink)
MCB Member
 
1shot's Avatar
 
Join Date: Apr 2013
Location: MN

I can except a cheap gun to be made of plastic and have sharp edges. I find it ridiculous that they fart when pumped hard. The mag well is a horrible design that they over complicated. It takes a lot of practice to change a mag with out it getting hung up. I have only shot reball with it and am unsure if I'm having velocity problems. What in the world were they thinking with the grip? A 45 grip frame that wrap around 1911 grips don't fit properly (not to mention the one that came on the gun.) They claim with the under cocking pump that it will except all my old barrels, and yet my Smart Parts progressive will not work. In many ways I would say the old Tiger Shark is better because that worked out of the box.
The farting really burns me up. I know people have backed out the pump guide rod but I'm worried that this may lead to other problems. I'm suspicious that this may lead to feed problems and potentially break the frame. That guide rod has a lot of play in it as soon as you loosen it. I don't know if lock tight or thread tape is enough to stabilize it properly. When I get around to it I plan on calling Kingman. I have a big game on 5 May. I'd like to really put it to the test then. I think it's bad form for them to put out a product that is severely flawed. I always liked Kingman stuff and have often recommend Spyders to people looking for very cheap guns. Now I'm questioning them as a company.
1shot is offline   Reply With Quote
Old 04-11-2013, 05:29 PM   #10 (permalink)
Post Whore
 
Join Date: Mar 2013
Location: Beantown, Kid!

Quote:
Originally Posted by 1shot View Post
Now I'm questioning them as a company.
You and me both.
Frizzle Fry is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Kingman

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 12:10 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC