mcarterbrown.com  

Reply
 
Thread Tools Search this Thread
Old 07-26-2008, 05:50 PM   #1 (permalink)
Active Member
 
Join Date: Jan 2008
Location: Arizona

Spyder Xtra issues

Working on getting my buddies back into paintball, one of them got a free spyder xtra from his brother in law. Hasn't been used/gassed up in years. He brought it buy, and we could NOT get it to recock. I used to shot spyder's years ago and felt pretty confident I could get it running. No dice so far, up for ideas.

We have:
Replaced main spring with heavier and lighter springs
Increased FPS
Replaced cup seal (figured while I was in there, I might as well)
Tried another trigger frame
Checked all orings for cracking
Replaced striker oring

I know, I haven't lubed yet, but it is still very well lubed. Might try anyway just to be sure. Also, don't have another hammer to try to see if its bad. Doesn't look any worse than my other spyder hammers, but that is the last thing I can think of. Any other ideas?

And a side note, where can I get a diffrent feedneck for this thing?

Thanks
__________________
AINT NO LOC TITE LIKE CROSSTHREAD!!!

Last edited by Mactruc; 07-26-2008 at 07:50 PM.
Mactruc is offline   Reply With Quote
Old 07-26-2008, 08:00 PM   #2 (permalink)
Only "PART" Canadian
 
Uranus's Avatar
 
Join Date: Mar 2006
Location: Burbank, Ca

does it fire at all? no leaks? Air in tank?
__________________
Quote:
Originally Posted by oldschool View Post
you'll do anything for *****.....
Uranus is offline   Reply With Quote
Old 07-26-2008, 08:18 PM   #3 (permalink)
Active Member
 
Join Date: Jan 2008
Location: Arizona

No leaks, not sure if it will actually fire a ball, no paint atm. It sounds like the end of tank fart, just a couple though. Like two, maybe three shots. Tank is at 1.5k, so i know its not an empty tank. Tried two tanks for that mater thinking one of them was acting screwy.
Thanks
Jay
__________________
AINT NO LOC TITE LIKE CROSSTHREAD!!!
Mactruc is offline   Reply With Quote
Old 07-26-2008, 08:27 PM   #4 (permalink)
Only "PART" Canadian
 
Uranus's Avatar
 
Join Date: Mar 2006
Location: Burbank, Ca

Sounds like it's not catching the sear.
__________________
Quote:
Originally Posted by oldschool View Post
you'll do anything for *****.....
Uranus is offline   Reply With Quote
Old 07-26-2008, 09:21 PM   #5 (permalink)
Active Member
 
Join Date: Jan 2008
Location: Arizona

Already tried another trigger frame, try another striker you think? And of course I dont have any slim strikers
__________________
AINT NO LOC TITE LIKE CROSSTHREAD!!!
Mactruc is offline   Reply With Quote
Old 07-27-2008, 12:51 AM   #6 (permalink)
Post Whore
 
Railgun's Avatar
 
Join Date: Oct 2006

It may well be that it's TOO well oiled. Too much oil slows down the striker and thus the amount of gas for both firing and recocking. Sort of like wiping your hand really fast over a puddle of water on the counter. If it was only just barely wet you can do this with no sense of pushing anything. But if you pour out a good puddle and then swipe it away you'll feel the resistance. It needs oil but it should only be a light smear that just makes the hammer look shiney without actually looking wet. Same with the bolt.

And make sure the sear isn't gummed up on the hinge pin with old lube or paintball splooge. If it is you may find that it catches with hand cocking but won't move fast enough to catch on a recock.

Because it's a blowback and sees air from the tank at all the parts just using the old trick of a few drops of oil into the ASA and then dry fire it without a barrel should result in enough oil getting to all the parts. But obviously for a strip and clean you want to smear on a light coat to cover it off.
__________________
I had a "Paintball God" moment once.
Like Al Bundy's Polk High football moment I live on
for the slim chance of repeating that one time
miracle in some small way.........
Railgun is offline   Reply With Quote
Old 07-27-2008, 03:22 AM   #7 (permalink)
Active Member
 
Join Date: Jan 2008
Location: Arizona

Thanks for the input, been there done that. In my younger days I was oil happy and learned that too much is sometimes worse than too little.

Off to find a striker, anyone wanna donate one to me
__________________
AINT NO LOC TITE LIKE CROSSTHREAD!!!
Mactruc is offline   Reply With Quote
Old 07-27-2008, 03:40 AM   #8 (permalink)
Only "PART" Canadian
 
Uranus's Avatar
 
Join Date: Mar 2006
Location: Burbank, Ca

Did you remember to put the striker bumper back in. I know I forgot that one all the time
__________________
Quote:
Originally Posted by oldschool View Post
you'll do anything for *****.....
Uranus is offline   Reply With Quote
Old 07-27-2008, 01:50 PM   #9 (permalink)
Active Member
 
Join Date: Jan 2008
Location: Arizona

Bumper there, installed behind striker, not in front (done that a few times). Its gotta be the striker, it HAS to be!
__________________
AINT NO LOC TITE LIKE CROSSTHREAD!!!
Mactruc is offline   Reply With Quote
Old 07-29-2008, 03:27 PM   #10 (permalink)
DAMAGE!
 
foster's Avatar
 
Join Date: Dec 2006
Location: Twin Cities MN

Strikers for Mech Triggers & E-Triggers may not be the same.
I had the striker from my stock mech trigger installed with an Egrip...no recock.
foster is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Kingman

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 12:48 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC