mcarterbrown.com  

Old Gun Tech Specific how-to's on fixing and tuning in those old guns

Reply
 
Thread Tools Search this Thread
Old 07-16-2013, 10:56 PM   #1 (permalink)
MCB Member
 
vv0mp's Avatar
 
Join Date: Mar 2011
Location: Calgary, AB

Bob long Species****

Front block comes off, looks like there is a place for a set screw to hold it in, but no where that would be accessible. Pics when I get home, but is this a simple fix?

If looking at the front of the gun without the block on it, you'd see:
O
o
o Between the two little o's is where the set screw would go..

Gun seems to be fine aside from that.
__________________
Quote:
Originally Posted by Donkey Oatey View Post
[You know you play pump..]When you carry extra 10 rounds just because you love to toss them to players screaming they need more paint.
Dr. VonDeafingson
I typically carry one extra tube and give them 1 ball from it.

I'm an *** like that.

My Feedback!

Last edited by vv0mp; 07-16-2013 at 11:34 PM.
vv0mp is offline   Reply With Quote
Old 07-16-2013, 11:01 PM   #2 (permalink)
WCP Scenario Paintball
 
Join Date: Sep 2012
Location: Central Virginia

IIRC remove the HPR, then there's a screw inside the ASA that holds the front block in place. That small screw you're seeing is a plug for an air passage.
Chooie is offline   Reply With Quote
Old 07-17-2013, 12:35 AM   #3 (permalink)
MCB Member
 
vv0mp's Avatar
 
Join Date: Mar 2011
Location: Calgary, AB

Solved!

Missing screw for sure.
Hopefully Ray has one that will fit.
__________________
Quote:
Originally Posted by Donkey Oatey View Post
[You know you play pump..]When you carry extra 10 rounds just because you love to toss them to players screaming they need more paint.
Dr. VonDeafingson
I typically carry one extra tube and give them 1 ball from it.

I'm an *** like that.

My Feedback!

Last edited by vv0mp; 07-17-2013 at 01:41 AM.
vv0mp is offline   Reply With Quote
Old 07-17-2013, 02:01 PM   #4 (permalink)
MCB Member
 
Spider!'s Avatar
 
Join Date: Dec 2008
Location: Houston, TX

Make sure it is the right length.

There is a difference in the way the screw fit between the pre-2k5, the 2k5 and/or the empire (evil?) aftermarket blocks. I think this may also have something to do with the body leaks caused by over-tightening the screw into the gas area. They changed which part was threaded, iirc, the block or the body.

I avoided the issue several years ago and just can't remember the various aspects. Just make sure the screw is holding where it is supposed to be holding. Those may just be separate issues.
__________________
My Feedback
Spider! is offline   Reply With Quote
Reply

  mcarterbrown.com » Museum » Old Gun Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 03:38 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC