mcarterbrown.com  

Reply
 
Thread Tools Search this Thread
Old 08-08-2013, 02:15 PM   #8921 (permalink)
MCB Member
 
vv0mp's Avatar
 
Join Date: Mar 2011
Location: Palm Springs, FL

Kilt Fan
My thumper loves the chrono station, but experiences stage fright mid game.

Also, rotors don't work on a thumper, loool.
__________________
Quote:
Originally Posted by Donkey Oatey View Post
[You know you play pump..]When you carry extra 10 rounds just because you love to toss them to players screaming they need more paint.
Dr. VonDeafingson
I typically carry one extra tube and give them 1 ball from it.

I'm an *** like that.

My Feedback!
vv0mp is offline   Reply With Quote
Old 08-21-2013, 09:37 AM   #8922 (permalink)
Post Whore
 
Chachi's Avatar
 
Join Date: Jul 2006
Location: Dayton, OH

So... is metadyne still around? Does anyone have a phone number for them? I'd like to send my thumper in for it's 40th shot servicing
__________________
-Wildcard


Thunderstruck

Quote:
Originally Posted by ~FinSec View Post
If it has tits or tires its gonna cause trouble.


Chachi is offline   Reply With Quote
Old 08-21-2013, 12:11 PM   #8923 (permalink)
Ebay, camocow200
 
woouulf's Avatar
 
Join Date: Jun 2009
Location: victorville ,Cali

Im sure someone has the email addy so you can get a RMA...
Send it insured with signature comf..
__________________
http://www.mcarterbrown.com/forums/f...-feedback.html

WTF,why would i trade for that?

Ebay, camocow200 (1190+) + 100% positive feedback
MCB 290 pos feedback

"Mar" bro: welcome to the forum, super nice marker - hopeful for your sale.
"stargazer" It's ma'am actually, not bro.
woouulf is online now   Reply With Quote
Old 12-06-2013, 10:22 PM   #8924 (permalink)
Newbie
 
Join Date: Dec 2013

Here's a copy-paste of what I just emailed him, anyone else have this problem? As far as I know I have all the latest parts.

I air the gun up and it leaks significantly down the barrel. As soon as the cocking latch (?) grips the hammer and pulls the hammer off of the three way valve the leak stops. The gun does not leak until I fire it, at which point the leak starts again. The piston is locked back and allows air to flow through the grip, through the three way valve, and out the piston down the barrel. It seems that the hammer is rotating too far/hard and pinning the pin of the three way valve forward. Almost as if there is too much force from the hammer spring. I have tried replacing the three way valve with two new valves and the problem persists. If it would help I could take pictures. I'm not sure what the official part names are as I do not have a manual.
El Capitan! is offline   Reply With Quote
Old 12-06-2013, 10:45 PM   #8925 (permalink)
Ebay, camocow200
 
woouulf's Avatar
 
Join Date: Jun 2009
Location: victorville ,Cali

Kinda sounds like you don't have your hammer spring set... But who knows,could be anything..
__________________
http://www.mcarterbrown.com/forums/f...-feedback.html

WTF,why would i trade for that?

Ebay, camocow200 (1190+) + 100% positive feedback
MCB 290 pos feedback

"Mar" bro: welcome to the forum, super nice marker - hopeful for your sale.
"stargazer" It's ma'am actually, not bro.
woouulf is online now   Reply With Quote
Old 12-07-2013, 01:14 AM   #8926 (permalink)
South African pump player
 
Happy Chewy's Avatar
 
Join Date: Mar 2011
Location: South Africa

That is an annoying issue just tighten the piston... Or at least i think that is the issue, either that or one of the piston o-rings blew off or aren't sealing.
__________________
Happy Chewy is offline   Reply With Quote
Old 12-07-2013, 01:28 AM   #8927 (permalink)
Newbie
 
Join Date: Dec 2013

Quote:
Originally Posted by woouulf View Post
Kinda sounds like you don't have your hammer spring set... But who knows,could be anything..
This might be a dumb question but how DO I set it? There's a little groove that you put it in, rotate the hammer around, and put it back together right? Something I noticed is that when I put the trigger assembly on the hammer "pops" forward on the three way pin. I don't know why it does this or if it's normal. It seems like the trigger assembly is pushing on the hammer spring a bit.

Quote:
Originally Posted by Happy Chewy View Post
That is an annoying issue just tighten the piston... Or at least i think that is the issue, either that or one of the piston o-rings blew off or aren't sealing.
I'll try this but I don't think this is the problem. The weird part is the leak immediately stops as soon as I relieve the slightest tension off the three way valve by re-cocking.
El Capitan! is offline   Reply With Quote
Old 12-07-2013, 01:36 AM   #8928 (permalink)
ur my sister
 
joedirt199's Avatar
 
Join Date: Apr 2009
Location: St Louis

Mine did the same thing and when I replaced the valve it stopped. The valves are pressure sensitive above 300 psi. After putting and external reg on the vertical asa set below 300 psi I quit ruining valves.
__________________
God created Police so Firemen would have HEROES
In God we trust, everyone else gets searched
9mm will make you weak!

MY FEEDBACK
http://www.mcarterbrown.com/forums/f...-feedback.html

CCM Works Sniper, Thumper, Kingman Hammer Low Pressure with Vertical ASA, TPX, Ion mech/closed bolt
joedirt199 is offline   Reply With Quote
Old 12-07-2013, 01:49 AM   #8929 (permalink)
Ebay, camocow200
 
woouulf's Avatar
 
Join Date: Jun 2009
Location: victorville ,Cali

Quote:
Originally Posted by El Capitan! View Post
This might be a dumb question but how DO I set it? There's a little groove that you put it in, rotate the hammer around, and put it back together right? Something I noticed is that when I put the trigger assembly on the hammer "pops" forward on the three way pin. I don't know why it does this or if it's normal. It seems like the trigger assembly is pushing on the hammer spring a bit.

( once i spring it back , i use and small allen wrench handle to hold it place while i put the 2 halves in place and tighten them down .Then i remove the handle gently with pray it wont bypass the the valve pin)...Some just hold it back with a thumb..I have big thumbs , no bueno por me...

I'll try this but I don't think this is the problem. The weird part is the leak immediately stops as soon as I relieve the slightest tension off the three way valve by re-cocking.
sounds real close to the hammer spring or the hammer going on and then over the valve pin..
__________________
http://www.mcarterbrown.com/forums/f...-feedback.html

WTF,why would i trade for that?

Ebay, camocow200 (1190+) + 100% positive feedback
MCB 290 pos feedback

"Mar" bro: welcome to the forum, super nice marker - hopeful for your sale.
"stargazer" It's ma'am actually, not bro.
woouulf is online now   Reply With Quote
Old 12-07-2013, 02:36 AM   #8930 (permalink)
Newbie
 
Join Date: Dec 2013

Quote:
Originally Posted by woouulf View Post
sounds real close to the hammer spring or the hammer going on and then over the valve pin..
I completely agree, but how would I fix this?
El Capitan! is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Pump Markers

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 12:39 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC