mcarterbrown.com

mcarterbrown.com (http://www.mcarterbrown.com/forums/)
-   Pump Markers (http://www.mcarterbrown.com/forums/pump-markers/)
-   -   Splatmaster seals, doesn't fire? (http://www.mcarterbrown.com/forums/pump-markers/215537-splatmaster-seals-doesnt-fire.html)

matteekay 10-08-2012 07:19 PM

Splatmaster seals, doesn't fire?
 
Hey folks,

Working on restoring a Splatty. I've gotten it to the point where it seals up when you tighten down a 12ie (no leak down the barrel or anything) but it doesn't fire. Well, it fires insofar as the hammer rams forward like it's supposed to (and hard) but no CO2 escapes. If I loosen the 12ie enough to get a little hiss down the barrel I can get a small "pop" when I fire it, though not enough to launch a paintball. Any ideas?

Thanks,
Matt

Bored383 10-08-2012 11:15 PM

check yer IM's and let me know

matteekay 10-08-2012 11:40 PM

Will do!

toymachine 10-18-2012 09:04 PM

What happened with your splatty?

matteekay 10-18-2012 09:29 PM

It appears the plunger is sheered off:

http://i32.photobucket.com/albums/d1...012_004607.jpg

Still need to take the valve body apart and see what's up.

toymachine 10-18-2012 10:40 PM

Bummer. Hope you're able to find success with her. I have a strong affection for ye ole splatty

matteekay 10-18-2012 10:51 PM

Not done yet ;) .


All times are GMT -4. The time now is 12:17 AM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC