mcarterbrown.com

mcarterbrown.com (http://www.mcarterbrown.com/forums/)
-   Pump Markers (http://www.mcarterbrown.com/forums/pump-markers/)
-   -   Lapco Grey Ghost cocking problem (http://www.mcarterbrown.com/forums/pump-markers/229770-lapco-grey-ghost-cocking-problem.html)

jellyghost 03-25-2013 11:49 PM

Lapco Grey Ghost cocking problem
 
I love my lapco grey ghost, but it does not consistently cock. In order for it to cock consistently, I have to adjust the velocity to the lowest setting. Is this a spring problem?

K_Obeastly 03-28-2013 03:23 AM

I've never run into this with mine, I would check out the sear and sear spring. It could be a main spring problem, I've run into that before on a bushmaster where the spring was too long and would not compress enough to allow the sear to latch. Do you know if it has the factory main spring in it?

jellyghost 03-28-2013 12:34 PM

It appears to be a factory spring. I found an old thread on this issue, and it suggested to try the phantom red spring. It also suggested the sear could be the problem. I will try the red spring before trying to figure out the sear. It has very little use on the gun, so I am a bit surprised by the problem.
Love the gun though. It will be joining the CCM and CCI in the permanent collection.

LibertyRadeon 04-07-2013 09:44 PM

Not sure if you solved it yet - I suggest contacting LAPCO, they've always been very helpful when I've had trouble with my GHost.


All times are GMT -4. The time now is 11:28 PM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC