mcarterbrown.com  

Reply
 
Thread Tools Search this Thread
Old 05-27-2011, 04:19 PM   #11 (permalink)
MaD
MCB Member
 
MaD's Avatar
 
Join Date: Oct 2007
Location: A2, Michigan

Yeah, check the "cup seal" face really closely. I suspect the seal has come out partially or is damaged. Also please do post up some pics of the parts and how you are assembling them.
__________________
Feedback

Quote:
Originally Posted by senghing27
ooops
Note: While I would love to take credit for his work, I am not associated with Mad Customs!
You can contact BigMatt-MadCustoms in his MCB forum
MaD is online now   Reply With Quote
Old 05-27-2011, 04:20 PM   #12 (permalink)
MCB Member
 
Rover's Avatar
 
Join Date: Oct 2009
Location: Saint John, New Brunswick




Holy not resized batman! sorry guys.

Chemist, I went down your steps. Everything -looks- to be good to me.

Is my assembly right? Thats the order I'm putting them in. The only piece I'm not entirely sure on is that top piece. Its like a circle of metal thats split, I think it goes around the spring where it touches the end piece.
Attached Images
 
__________________
My Feedback
Rover is offline   Reply With Quote
Old 05-27-2011, 04:27 PM   #13 (permalink)
MaD
MCB Member
 
MaD's Avatar
 
Join Date: Oct 2007
Location: A2, Michigan

That split ring goes on the back of the chamber plug.Just put it on the back of the chamber plug then slide that into the brass tube. The rest looks like you have the correct order.

How's the 12g face seal look?
__________________
Feedback

Quote:
Originally Posted by senghing27
ooops
Note: While I would love to take credit for his work, I am not associated with Mad Customs!
You can contact BigMatt-MadCustoms in his MCB forum
MaD is online now   Reply With Quote
Old 05-27-2011, 04:30 PM   #14 (permalink)
MCB Member
 
Rover's Avatar
 
Join Date: Oct 2009
Location: Saint John, New Brunswick

12 gram face seal looks good...

I'm going to change back to my old valve, not the palmers one. Maybe it will work for me.

Thanks for the heads up on the split ring, thats where I had been putting it. I'm just not too sure on all the terminology.
__________________
My Feedback
Rover is offline   Reply With Quote
Old 05-27-2011, 04:40 PM   #15 (permalink)
MCB Member
 
Rover's Avatar
 
Join Date: Oct 2009
Location: Saint John, New Brunswick

Update -

Well, its an improvement!

Now it just leaks out slowly. Enough that the thing will run dry in the length of a game, but not enough to make it unuseable.

When I pump it, it leaks out the back until i push the bolt forward, then it leaks down the barrel like normal. I suspect that must be something on the valvestem?
__________________
My Feedback
Rover is offline   Reply With Quote
Old 05-27-2011, 04:57 PM   #16 (permalink)
MaD
MCB Member
 
MaD's Avatar
 
Join Date: Oct 2007
Location: A2, Michigan

It could be that seal. One of those seals is bad or it's not together right. You sure you're tightening it down enough? I mean it doesn't have to be crazy tight in there but they do need to be fairly snug in there for the seals to work.
__________________
Feedback

Quote:
Originally Posted by senghing27
ooops
Note: While I would love to take credit for his work, I am not associated with Mad Customs!
You can contact BigMatt-MadCustoms in his MCB forum
MaD is online now   Reply With Quote
Old 05-27-2011, 05:01 PM   #17 (permalink)
MaD
MCB Member
 
MaD's Avatar
 
Join Date: Oct 2007
Location: A2, Michigan

Is that an illusion or is the back end of that "brass tube" all chewed up?
__________________
Feedback

Quote:
Originally Posted by senghing27
ooops
Note: While I would love to take credit for his work, I am not associated with Mad Customs!
You can contact BigMatt-MadCustoms in his MCB forum
MaD is online now   Reply With Quote
Old 05-27-2011, 05:30 PM   #18 (permalink)
MCB Member
 
Rover's Avatar
 
Join Date: Oct 2009
Location: Saint John, New Brunswick

Illusion, it has some tiny little nicks around the edge, but it should be fine against the O-ring.
__________________
My Feedback
Rover is offline   Reply With Quote
Old 05-27-2011, 06:37 PM   #19 (permalink)
Wookie D*ck
 
russc's Avatar
 
Join Date: Apr 2006
Location: Vancouver, BC

There are three things that could cause this leak.

The oring that goes on the brass valve body
the rubber seal on the valve stem
the brass face of the valve that contacts the valve stem.
__________________
Quote:
Originally Posted by agentSmith View Post
oldschool play is about sportsmanship and respect, oldschool gear is available on Ebay.
russc is offline   Reply With Quote
Old 05-27-2011, 08:12 PM   #20 (permalink)
MCB Member
 
Rover's Avatar
 
Join Date: Oct 2009
Location: Saint John, New Brunswick

I may as well just buy replacements for all those parts. (Save the brass valve piece, not much I can do for that.)

Anyone know a decently priced place to get them for a canadian? MaD, do you have any in stock?
__________________
My Feedback
Rover is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Sheridan

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 02:44 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC