mcarterbrown.com  

Tiberius Arms Everything Tiberius

Reply
 
Thread Tools Search this Thread
Old 06-21-2014, 01:42 PM   #1 (permalink)
Canada eh?
 
Join Date: Jan 2012
Location: Ottawa, Canada

T8.1 problem "bolt bounce"

I just bought an 8.1 off Craig's list for dirt cheap. It has a case of I don't what... bolt bounce? Sounds Like an A5 running low on air it makes that sound like full auto fire.

I took it all apart polished the internals, cleaned, lubed, and with the bolt in the forward position I reassembled it. It shoots the first couple shots then starts bouncing... Pow, pow, pow, pa,pa,pa,pa..

Could the regulator be eff'ed? If you could point me in the right direction it would be much appreciated.
__________________
Feed back thread

Last edited by Z3R0S1GN4L; 06-21-2014 at 01:47 PM.
Z3R0S1GN4L is offline   Reply With Quote
Old 06-21-2014, 03:33 PM   #2 (permalink)
Seasoned Member
 
Tick's Avatar
 
Join Date: Jun 2010
Location: portland or

Tiberiusarm's.com/forums
More info than I can sort through! Good luck!
Tick is offline   Reply With Quote
Old 06-22-2014, 02:53 AM   #3 (permalink)
all work
 
Join Date: Jan 2011

It sounds as if the sear isn't catching the spool.
Nightstar is offline   Reply With Quote
Old 06-22-2014, 08:15 PM   #4 (permalink)
Canada eh?
 
Join Date: Jan 2012
Location: Ottawa, Canada

Took it all apart again, this time took all the trigger components apart as well, the previous guy didn't have the sissor spring or the hook spring in the right way. Works perfect now. Thanks.
__________________
Feed back thread
Z3R0S1GN4L is offline   Reply With Quote
Old 06-22-2014, 11:54 PM   #5 (permalink)
Seasoned Member
 
Tick's Avatar
 
Join Date: Jun 2010
Location: portland or

Way cool! I did a magnet trigger mod for mine...works very good! Welcome to the pistol ranks!!
Tick is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Tiberius Arms

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 08:58 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC