mcarterbrown.com  

Reply
 
Thread Tools Search this Thread
Old 03-17-2014, 09:35 AM   #1 (permalink)
Sniper Lifer - 68
 
Join Date: Mar 2012
Location: Yarmouth NS

TPX venting

My TPX has started venting gas after it fires until the trigger comes completly forward. Any ideas as to what/why this is? I now only get 1.5 clips out of a 12 gram as well.

help me obi-wan kenobi! You're my only hope!

WFW
wetfootwilley is offline   Reply With Quote
Old 03-17-2014, 11:23 AM   #2 (permalink)
Addict.
 
MEDuck's Avatar
 
Join Date: Feb 2012
Location: Maine

CCM Fan
Venting out the back?
__________________
Rubber Duckies Paintball
Ninja Squad Paintball
518th Brigade
Quote:
Originally Posted by shadawg View Post
The cool thing about Buddhist monks is when they light themselves on fire in Martyrdom, they don't hang around for 7 years to tell you they are burning.
Feedback Please!
MEDuck is online now   Reply With Quote
Old 03-17-2014, 02:10 PM   #3 (permalink)
Sniper Lifer - 68
 
Join Date: Mar 2012
Location: Yarmouth NS

No - just hissing and leaking around the trigger or out the barrel. I'll gas it up again tonight to really give better details, it just struck me as odd because it was only until I got the trigger released between shots.
wetfootwilley is offline   Reply With Quote
Old 03-17-2014, 03:35 PM   #4 (permalink)
Active Member
 
scribbleheli's Avatar
 
Join Date: Mar 2013

Might be the seal near the puncture pin?
I had similar issue but using hpa/remote
I put a drop of oil on the front of my 12g and tightened the set screw a tiny bit. Solved my leak.
Mine sounded like it was venting down the mag well area tho.
scribbleheli is offline   Reply With Quote
Old 03-17-2014, 09:56 PM   #5 (permalink)
Sniper Lifer - 68
 
Join Date: Mar 2012
Location: Yarmouth NS

I'll give that a look when I take it apart. I've been looking at the set screw on the c02 plug too.
wetfootwilley is offline   Reply With Quote
Old 03-20-2014, 03:07 PM   #6 (permalink)
Sniper Lifer - 68
 
Join Date: Mar 2012
Location: Yarmouth NS

OK - it's venting between trigger pulls, looks like it might be a bad tiny oring on the gas transfer tube between the pierce assembly/trigger actuator and the regulator. Bummer - I need it for this weekend, and I'll never get a spare oring for that in time.
wetfootwilley is offline   Reply With Quote
Old 03-31-2014, 04:46 PM   #7 (permalink)
Active Member
 
Join Date: Jan 2008
Location: Bialystok, POLAND

I have the same issue.
Venting from puncture pin assembly (the tiny orings have a good seal-checked by spitting on them with my TPX open and minimum amount of gas from my HP tank)
I think it might be the oring at the puncture pin itself-but it looks fine.
wetfootwilley-did you manage to solve the problem?
EDIT: I'm 98% positive it's the oring on the puncture pin (part 42) Can't find anything on the oring though
EDIT2: the inside of the 42 oring looks fishy will inquire further
__________________
REACTOR ONLINE. SHIELDS ONLINE. FLUX CAPACITORS ONLINE. VSC PHANTOM OPERATIONAL...
My feedback

Last edited by rogalxxx; 03-31-2014 at 05:38 PM.
rogalxxx is offline   Reply With Quote
Old 03-31-2014, 05:17 PM   #8 (permalink)
Active Member
 
Join Date: Jan 2008
Location: Bialystok, POLAND

OK
I think I've found the cause!

the metal on puncture pin got shaved a bit with every trigger pull. the chips and shavings damaged the oring on the inside and acumulated inside the puncture pin assembly as black dust I found.
here's the inside of the oring

now to find a replacement for this bugger but what about the puncture pin? Should I lube it or polish the thing with 2000grit paper?
__________________
REACTOR ONLINE. SHIELDS ONLINE. FLUX CAPACITORS ONLINE. VSC PHANTOM OPERATIONAL...
My feedback

Last edited by rogalxxx; 03-31-2014 at 05:22 PM.
rogalxxx is offline   Reply With Quote
Old 06-04-2014, 06:32 AM   #9 (permalink)
Sniper Lifer - 68
 
Join Date: Mar 2012
Location: Yarmouth NS

I emailed tippman, and they're sending out a puncture assembly and a firing pin assembly. Great customer service BTW. Hopefully this fixes it for me. I am starting to think mine might have the same problem as yours Rogal.

WFW
wetfootwilley is offline   Reply With Quote
Old 06-16-2014, 04:11 PM   #10 (permalink)
Seasoned Member
 
Rover Lead's Avatar
 
Join Date: Jul 2011
Location: Monterey Bay, CA

Yeah Tippmann customer service is great.
Rover Lead is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Tippmann

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 12:54 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC