mcarterbrown.com  

Reply
 
Thread Tools Search this Thread
Old 07-25-2014, 08:26 PM   #1 (permalink)
Active Member
 
Join Date: Mar 2009
Location: AZ

Question SL 68 II question

Hello all,

I have just picked up a tippman sl 68 II pump. after taking it all apart & cleaning it. I tried it for the first time. I wanted to know if this is normal. When you pump it air will leak out the valve side opening for a split 2nd. then when you put pump grip back to front position, no leak. normal or not. 2nd no auto trigger ? while holding on trigger pull pump back then forward no AT movement ? Help me out please.

thanks for your time (ulle)
pumpkid025 is offline   Reply With Quote
Old 07-25-2014, 08:45 PM   #2 (permalink)
MIKE WAZOWSKI!!!
 
cheapchi's Avatar
 
Join Date: Jan 2010

Not normal but I am hoping that more educated members can help you diagnose things.

I own one but have never needed to trouble shoot this type of issue.

As far as the leak when you pump, check the valve for nicks.

As far as not being able to auto trigger check that the pump handle is not screwed on far enough. Add a turn and recheck.
__________________
cheapchi's feedback
cheapchi is offline   Reply With Quote
Old 07-26-2014, 12:20 PM   #3 (permalink)
aka Maggy Moo
 
magmoormaster's Avatar
 
Join Date: Jun 2009
Location: Provo, UT

The valve will leak while pumping if you are A) low on air or B) pump really hard. With any nelson valve, the air in the valve chamber holds the valve closed while you pump. If you are low on air then there is less force holding the powertube forward so it's easier to overcome and pop the valve open.

The gun should autotrigger. As mentioned, make sure the pump handle is in far enough.
__________________
Feedback

WTT 16" Stiffi Switch Tip for a 12" or 14" Tip
magmoormaster is online now   Reply With Quote
Old 07-26-2014, 12:38 PM   #4 (permalink)
MCB Member
 
funsi00's Avatar
 
Join Date: Jul 2006
Location: Cleveland, Ohio

CCM Fan
Brass N Wood Fan
Palmers Fan
Un thread the pump arm 1-2 turns counter clockwise. Might be set too short for auto trigger function.
__________________
My feedback on MCB : http://www.mcarterbrown.com/forums/f...-feedback.html
Brass Mafia - team status S4



funsi00 is online now   Reply With Quote
Old 08-03-2014, 09:18 PM   #5 (permalink)
MIKE WAZOWSKI!!!
 
cheapchi's Avatar
 
Join Date: Jan 2010

Everything work out?
__________________
cheapchi's feedback
cheapchi is offline   Reply With Quote
Old 08-03-2014, 09:31 PM   #6 (permalink)
Active Member
 
Join Date: Mar 2009
Location: AZ

yep go everything to work thanks you all for your help.

making custom barrel for this as well. ACI 16 inch with phantom pump handle.

thanks mod you can close thread please.
pumpkid025 is offline   Reply With Quote
Old 08-04-2014, 10:10 PM   #7 (permalink)
MIKE WAZOWSKI!!!
 
cheapchi's Avatar
 
Join Date: Jan 2010

Just for my own edification was the pump handle not screwed in enough OR screwed in too far?
__________________
cheapchi's feedback
cheapchi is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Tippmann

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 11:32 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC