mcarterbrown.com

mcarterbrown.com (http://www.mcarterbrown.com/forums/)
-   WDP (http://www.mcarterbrown.com/forums/wdp/)
-   -   Angel LCD board/screen ?/issue (http://www.mcarterbrown.com/forums/wdp/207402-angel-lcd-board-screen-issue.html)

waytoorandom 07-05-2012 08:07 PM

Angel LCD board/screen ?/issue
 
Hello,
I just picked up a Dark LCD. I tried charging it, and the battery seems to charge. However, the screen lights up but does not display anything. I cannot take the gun off safe or fire it. Eventually, the light on the board goes off.

Is the screen fried? Any help would be appreciated.

shooter4life 07-05-2012 09:34 PM

Ok, have you owned an angel before. Not being a smart ***, just curious if you are trying to turn it on properly. Holding the top button on the frame should change the safe to fire. If you are not getting that and it is saying pin...try entering all 0000s. It sounds like its a battery issue. Any faults on the screen when it is lit up?

gainman 07-05-2012 10:47 PM

sometimes when older angels have been not used for a really long time the battery drains into what i like to call oblivion mode. even if you plug it into the charger it does a weird thing with the screen where it kind of turns on the light, but does not diplay anything, then turn off again. if you play with it (plug it in and unplug it) you can usually get it to actually boot up properly. remember that for the angel to charge the switch must be in the on position. what seems to work for me most of the time is have the switch off, plug the charger in, turn the switch on. when the board does the weird cycle thing, unplug the charger but leave the switch on, wait a couple secs, then plug the charger back in. at this point it seems to boot up. sometimes i have to turn the switch off then back on again.

either way, the battery is pretty much on its way out and youll notice it wont hold a charge as well anymore.

waytoorandom 07-06-2012 10:41 AM

Shooter- I have owned many Angels, and have a 2k3 LCD LE and a 99 LED right now. The Dark actually didnt come with a charger, had to use the one from the LE. it does not say tab in or need a pin, it doesn't display anything at all on the lcd.

Gainman- I believe this is the issue. I will try the battery from the 2k3 (which i also had to replace originally...) to try and narrow down the issue to a battery one. First, I will try the exact plug/unplug/on/off procedure you mentioned. I am seriously considering dropping in a pm7 virtue board since you can get those for 35$ new right now, or maybe a hater board (same price).

gainman 07-06-2012 05:17 PM

assuming the pm7 board is the same as the pmr hookup wise, shouldnt be a problem. its a really easy swap and works great.

waytoorandom 07-07-2012 10:54 AM

yeah, the rail and m7 board is the same board. also the same one that's in the 07 Minion.

I have a spare 06 proto board, and that won;t work, it's too big and the part you would have to trim has wiring on it.


All times are GMT -4. The time now is 03:09 AM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC