mcarterbrown.com
 

Reply
 
Thread Tools Search this Thread
Old 04-13-2012, 10:23 AM   #1 (permalink)
flinging poo
 
paintballmonkey's Avatar
 
Join Date: Feb 2012
Location: Pensacola, Florida

Trigger stick in Benchmark Slider

I bought a benchmark slider frame here knowing up front about this issue. I am trying to troubleshoot it but not having any luck. When I pull the trigger, it stays in the rearward position. With a little nudge I can get it it to spring back forward. I stretched the sear spring a little and even used another, firmer spring with no luck. Any help is greatly appreciated.
paintballmonkey is offline   Reply With Quote
Old 04-13-2012, 10:29 AM   #2 (permalink)
Official LL5 Dolphin-Dive
 
PistolRogue's Avatar
 
Join Date: Jan 2009
Location: Jackson, NJ
Send a message via AIM to PistolRogue

Is there anything in the groove that the trigger plate sits in? Sounds like there might be some gunk or something built up in the corners of the rear of the groove or maybe a burr on the plate itself?
__________________
Jay AKA Rogue Reservoir Dogs Scenario Paintball Team- Our $#&* is RIGOROUS!
My Gear For SALE!
Check Out My Mod Threads : Pirate DSG - SA17 Mods - Simple/Cheap/Free TPX Mods - The 'Big Damn Hero' DRV
FEEDBACK
PistolRogue is offline   Reply With Quote
Old 04-13-2012, 10:29 AM   #3 (permalink)
MCB Member
 
wd3d's Avatar
 
Join Date: Nov 2008
Location: Clever Mo.
Send a message via Yahoo to wd3d

Just had a similar problem. The return spring had gotten jammed beside the trigger plate. I replaced mine with an ink pen spring. Works fine now.
wd3d is offline   Reply With Quote
Old 04-13-2012, 11:17 AM   #4 (permalink)
flinging poo
 
paintballmonkey's Avatar
 
Join Date: Feb 2012
Location: Pensacola, Florida

Thanks. I will tap out the sear pin and take a peek.
paintballmonkey is offline   Reply With Quote
Old 04-13-2012, 03:01 PM   #5 (permalink)
makin bacon
 
baconquilt's Avatar
 
Join Date: Mar 2012

try loosening the bottom adjustment screw a tad

if you have one
baconquilt is offline   Reply With Quote
Old 04-13-2012, 08:39 PM   #6 (permalink)
flinging poo
 
paintballmonkey's Avatar
 
Join Date: Feb 2012
Location: Pensacola, Florida

Quote:
Originally Posted by wd3d View Post
Just had a similar problem. The return spring had gotten jammed beside the trigger plate. I replaced mine with an ink pen spring. Works fine now.
The return spring was MIA. I used your ink pen spring trick and it now works beautifully. Thanks for a no-cost fix!
paintballmonkey is offline   Reply With Quote
Old 04-13-2012, 09:41 PM   #7 (permalink)
MCB Member
 
wd3d's Avatar
 
Join Date: Nov 2008
Location: Clever Mo.
Send a message via Yahoo to wd3d

Glad to be of assistance...
wd3d is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » WGP

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 06:02 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC