mcarterbrown.com

mcarterbrown.com (http://www.mcarterbrown.com/forums/)
-   WGP (http://www.mcarterbrown.com/forums/wgp/)
-   -   New CCM internals - What did I do wrong? (http://www.mcarterbrown.com/forums/wgp/231129-new-ccm-internals-what-did-i-do-wrong.html)

Patar 04-11-2013 12:47 PM

New CCM internals - What did I do wrong?
 
A while back I bought a bunch of upgrades for my nightkast, ccm lower tube kit and pump kit, installed everything... Gun was working fine mechanically, just testing it all at the house with no air. Wasn't able to get my tank filled or hit the field for a while until yesterday.

It's not holding air. At first it just sounded like air was leaking from multiple places? But as I kept attempting to hotfix and gas it up again, it sounded like it was leaking down the barrel more.

Something with the valve I assume?

Frenchy 04-11-2013 12:53 PM

Have you pumped the gun prior to airing it up?

What's your reg set at? Do you know?

river031403 04-11-2013 12:54 PM

Did you cock it / pump it before you aired it up?

EgoPossum 04-11-2013 12:55 PM

Leaking down the barrel:

I assume that you cocked the gun first (even I forget to do that)

The only o-rings that would cause that leak are the poppit o-ring or valve body o-ring
The only other thing that would cause that problem would be if the spring was sitting funny (I have totally forgot the poppit spring once)

Phone CCM if you have any questions. Rod is amazing at helping trouble shoot issues that you are having with their stuff.

Patar 04-11-2013 01:05 PM

the first time I did not cock it before i aired it up. the second time I did. Both time leaked.

Not cocking the gun means what? the hammer is resting on the valve and leaving it open? Even after cocking it didn't change :s I let the air leak for a sec and it stopped leaking so intensely and that's when it started leaking down the barrel instead of just all-around leaking.

I'm gunna pop open the valve-side internals and take a look in a second, see if anything doesnt look right. Tbh it's highly possible i didn't seat something correctly when I put them all in lol. Herpaderpderp.

@frenchy, dunno what my reg is set at. No gauge or pressure tester :s

river031403 04-11-2013 01:30 PM

Make sure you have the valve right side up whole aligning correctly

Patar 04-11-2013 01:34 PM

Will do.

Looked through the autococker info sheet some too, going to look at some of those issues.

Thinking it's either the valve spring, valve not being seated correctly, or my pressure/rag is outta whack.

Frustrating, but I got an autococker knowing full well I'd have to tinker with it :p

P.S. - cheap valve tools? someone on MCB makes them, don't they? for a few bucks.

Dysturbed87 04-11-2013 01:59 PM

Quote:

Originally Posted by Patar (Post 2681123)
P.S. - cheap valve tools? someone on MCB makes them, don't they? for a few bucks.

I believe that would be stanchy or titus

river031403 04-11-2013 01:59 PM

Super stanchy

Patar 04-11-2013 02:05 PM

alright, ordered one for titus/celanis PB, thanks dudes. Using the cocking rod was a pain :p


All times are GMT -4. The time now is 04:44 AM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC