mcarterbrown.com  

Reply
 
Thread Tools Search this Thread
Old 02-18-2015, 11:13 PM   #1 (permalink)
Balling since '87
 
mobiusmorte's Avatar
 
Join Date: Apr 2007
Location: Tampa, FL

E-Mag trouble

I've got an e-mag that is just giving me headaches, Level 10 is installed no leaks but the gun will not fire mechanically (won't fire electronically either thanks to the bad battery pack, need to order a replacement) I've tweaked the firing assembly but it will just not fire. The on/off is correct (I believe) and seems to be functioning normally, the only time I can get it to fire is if I remove the sear guide pin (the one that screws in from the side of the rail) it will then fire but it goes into full auto mode since the sear doesn't catch the bolt. Logic tells me that the sear when installed correctly is not actuating the on/off but no amount of tweaking to the trigger rod length is alleviating the issue. With the valve out the sear seems to rise flush to the inner body (where the on/off would be) but once the valve is in the sear no longer wants to travel at all (it acts like it is stuck or jammed) I did swap the original chrome powerfeed body for a black powerfeed body could this be the cause? Is the e-mag body thinner? To my naked eye they look the same.
I've had this marker for several years now, originally after purchasing it used it would at least fire electronically but it never did operate mechanically for me could it be a bad trigger assembly? If so is there anyone still selling them? I am also open to sending it to a reputable shop for a tune-up but I know very little about the automag world and would love some suggestions as far as that goes.
Any help offered would be greatly appreciated.
__________________
My current collection: Apex,Vector,Classic Intimidator (x2), Clamshell Intimidator, Angel LCD, F-4, F-2, Eagle .68,Shoebox Shocker, SFT Shocker (x2), Tactical Ion, Xonik Vengeance, e-Blade Orracle, Mech Vengeance, Nova, SuperNova (x3), .68 Special, Pro/Am, Tiberius T9, E-Mag, Pro-Lite, A5, NME LE, NME (x2), Impulse


[/INDENT]https://www.mcarterbrown.com/forums/f...tml#post147894
mobiusmorte is offline   Reply With Quote
Old 02-19-2015, 05:32 AM   #2 (permalink)
Post Whore
 
Cyco-Dude's Avatar
 
Join Date: Mar 2011

i would take a look at the sear. take the body off, remove the sear pin, then take the rail off the frame. you'll need to remove the 'e' clip on the plunger to take the sear assembly out. the trigger rod length should be 2.125", and the solenoid plunger should be set at 3.005" (measured from the tip of the plunger to the end of the clevis). also check to make sure the sear isn't chipped / worn out on the edge were it would contact the bolt.

the on/off pin should measure .712", and there should be a quad o-ring in the valve.

you can send it out to agd and they could tech it for you i'm sure. i'll offer to check it out for you as well. i've rebuilt automags of all kinds, including emags, and i'll put my work up against anyone's!
__________________
Quote:
Originally Posted by alpha434 View Post
Barrels are like girls... Some people are just happy to have one that looks good. Or even one that everyone else likes. Other people want a tight, accurate bore to run their balls through.
Cyco-Dude is offline   Reply With Quote
Old 02-19-2015, 09:07 AM   #3 (permalink)
Balling since '87
 
mobiusmorte's Avatar
 
Join Date: Apr 2007
Location: Tampa, FL

Thank you for the advice, I'll break out the calipers and start measuring. If it all checks out but I still can't get it working I may just take you up on your offer.
I really do love the community here on MCB, with very few exceptions.
__________________
My current collection: Apex,Vector,Classic Intimidator (x2), Clamshell Intimidator, Angel LCD, F-4, F-2, Eagle .68,Shoebox Shocker, SFT Shocker (x2), Tactical Ion, Xonik Vengeance, e-Blade Orracle, Mech Vengeance, Nova, SuperNova (x3), .68 Special, Pro/Am, Tiberius T9, E-Mag, Pro-Lite, A5, NME LE, NME (x2), Impulse


[/INDENT]https://www.mcarterbrown.com/forums/f...tml#post147894
mobiusmorte is offline   Reply With Quote
Old 02-19-2015, 09:16 AM   #4 (permalink)
Balling since '87
 
mobiusmorte's Avatar
 
Join Date: Apr 2007
Location: Tampa, FL

Just finished checking out your links, that is some nice work. Very informative and helpful, I will try to document my upcoming work as well as you did.
__________________
My current collection: Apex,Vector,Classic Intimidator (x2), Clamshell Intimidator, Angel LCD, F-4, F-2, Eagle .68,Shoebox Shocker, SFT Shocker (x2), Tactical Ion, Xonik Vengeance, e-Blade Orracle, Mech Vengeance, Nova, SuperNova (x3), .68 Special, Pro/Am, Tiberius T9, E-Mag, Pro-Lite, A5, NME LE, NME (x2), Impulse


[/INDENT]https://www.mcarterbrown.com/forums/f...tml#post147894
mobiusmorte is offline   Reply With Quote
Old 02-19-2015, 10:50 AM   #5 (permalink)
Post Whore
 
Cyco-Dude's Avatar
 
Join Date: Mar 2011

good luck! hopefully nothing is damaged...emag parts are expensive!
__________________
Quote:
Originally Posted by alpha434 View Post
Barrels are like girls... Some people are just happy to have one that looks good. Or even one that everyone else likes. Other people want a tight, accurate bore to run their balls through.
Cyco-Dude is offline   Reply With Quote
Old 02-19-2015, 06:23 PM   #6 (permalink)
Seasoned Member
 
Join Date: Feb 2014
Location: Oklahoma

you can also send it to BigEvil or Tunaman to be worked on, I sent mine to BigE a few weeks ago and i'm very happy with it.
vintage is offline   Reply With Quote
Old 02-23-2015, 04:27 PM   #7 (permalink)
Balling since '87
 
mobiusmorte's Avatar
 
Join Date: Apr 2007
Location: Tampa, FL

I did not photograph my work but I did take the sear apart and adjust the parts to spec The trigger rod length was just over 2.2" in length so I shortened that accordingly. The solenoid plunger rod measured spot on so I left it alone. Put it all back together and it now works
or
so
I
Thought
Turns out I forgot to put the "c" clip back on the plunger, opened up the grips re-installed the clip and now the damn thing won't fire
Removed the clip again and it fires...

Obviously I measured incorrectly and need to adjust the length.
I will report back here after I get that done.

One question though If I only shoot mechanically is there any harm to not having that "c" clip back in place?
__________________
My current collection: Apex,Vector,Classic Intimidator (x2), Clamshell Intimidator, Angel LCD, F-4, F-2, Eagle .68,Shoebox Shocker, SFT Shocker (x2), Tactical Ion, Xonik Vengeance, e-Blade Orracle, Mech Vengeance, Nova, SuperNova (x3), .68 Special, Pro/Am, Tiberius T9, E-Mag, Pro-Lite, A5, NME LE, NME (x2), Impulse


[/INDENT]https://www.mcarterbrown.com/forums/f...tml#post147894
mobiusmorte is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Air Gun Designs

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 02:46 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO
© MCB Network LLC