mcarterbrown.com  

Reply
 
Thread Tools Search this Thread
Old 06-30-2010, 05:46 PM   #1 (permalink)
Active Member
 
Zerbob's Avatar
 
Join Date: Mar 2009
Location: Whitby, Ontario, Canada

Getting rid of a little flutter

Several months ago I picked up a Pro Lite from the States for pretty cheap (was like $30). It worked great until a few months ago when the bolt started to flutter when I shot. Instead of firing once, then returning behind the sear it would go two or three times before going to an uncocked position. Any ideas on how I could solve this would be appreciated.

Zerbob
__________________
Think of it not as "hopelessly outnumbered", but rather as a "target rich environment".
Zerbob is offline   Reply With Quote
Old 07-01-2010, 10:52 AM   #2 (permalink)
Active Member
 
Radar's Avatar
 
Join Date: Dec 2008
Location: Carleton Place, ON

It's most likely your sear and/or hammer. Check your sear to see if its rounded at the edge where it makes contact with the hammer, if so it needs to be replaced, and check the hammer where the sear rest's. The hammer should have a 90 deg. cut, if its worn it could look like a 70 deg. cut. Use a file to get it back to 90 deg. It should work for a little longer, but will also need to be replace in the near future. Good luck.
__________________


Team Endeavour
O.P.S. Ottawa Paintball Supplies
2130 ROBERTSON ROAD.
Bells Corners, ON.
613-244-1645
Radar is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » Local Games » Canada

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 08:23 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO
© MCB Network LLC