mcarterbrown.com  

Empire Mini - Axe - Empire Sniper

Reply
 
Thread Tools Search this Thread
Old 04-11-2017, 05:11 PM   #21 (permalink)
Bad Juju
 
Join Date: Nov 2011
Location: Wichita, KS

I loved my morph valve in my sniper, but was not able to get more than a few hundred shots before it required lubrication and had to go back to the standard valve. It made me sad to do so, I really did love how quiet the shot became. Had multiple refs tell me they couldn't even hear me shoot. Same thing when playing against a buddy who had a morph installed in his trilogy pump, I could barely hear it. He's had much better luck with the lubrication than I did.
ClarkGryphyn is offline   Reply With Quote
Old 06-06-2017, 03:13 PM   #22 (permalink)
Rec Poster
 
Join Date: Mar 2017

Ya I installed mine in this weekend, but the problem i had was if I left my sniper unshot for a minute or longer it would shoot the first ball like it had very little air. Then shoot the second with like half air up, then the 3rd shot would come out like normal.

What fo you guys mean by lubing it up?

And I have the inceptions hammer and when I switch the delrin out for the inceptions hammer I have no problems with shooting velocity.
Whiteboy2242 is offline   Reply With Quote
Old 06-08-2017, 06:26 PM   #23 (permalink)
Bad Juju
 
Join Date: Nov 2011
Location: Wichita, KS

Quote:
Originally Posted by Whiteboy2242 View Post
Ya I installed mine in this weekend, but the problem i had was if I left my sniper unshot for a minute or longer it would shoot the first ball like it had very little air. Then shoot the second with like half air up, then the 3rd shot would come out like normal.

What fo you guys mean by lubing it up?

And I have the inceptions hammer and when I switch the delrin out for the inceptions hammer I have no problems with shooting velocity.
Yeah, that's exactly what I'm talking about. You need to lubricate the valve a bit. You could disassemble your marker and pull the valve back out, take it apart and lube the o-rings, or you could try putting a couple of drops of oil into the marker past the regulator (unscrew the reg and hold the marker upside down, put the oil in, put the reg back on, fire some shots). Hopefully the second way works. Much easier than the first way.
ClarkGryphyn is offline   Reply With Quote
Old 11-21-2017, 10:04 AM   #24 (permalink)
Old gear!
 
Join Date: Oct 2007
Location: Dallas

Anyone try quad rings in one yet? They're supposed to hold grease well, but I'm not sure the shape would be all that great for the closing action.

Edit: Got my sniper, fixed it up, and swapped the o-rings on the poppet. The front and back are now both black Buna 011, as well as the bumper inside the spring chamber. The valve started to move much more freely with the Buna than the urethane. Kept the stock spring and Delrin hammer.

I flipped the second from bottom Belleville washer in the regulator, set the IVG flush, and boom, with junk paint I was getting 277, 290, 280. Went and played all day without even adjusting velocity.

Looking at the valve, each o-ring will slightly protrude into the opening at some point; for this reason, my quad rings are unused. If anyone wants some, PM me. I wouldn't recommend it though.
__________________
Quote:
700 shipped Possibly pending member applying for loan
Only on MCB...

https://www.mcarterbrown.com/forums/f...-feedback.html

Last edited by flyweightnate; 12-11-2017 at 06:57 AM.
flyweightnate is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Empire

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 11:14 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO
© MCB Network LLC