mcarterbrown.com

mcarterbrown.com (https://www.mcarterbrown.com/forums/)
-   CCM (https://www.mcarterbrown.com/forums/ccm/)
-   -   6.5 trigger seems to be not catching? (https://www.mcarterbrown.com/forums/ccm/226417-6-5-trigger-seems-not-catching.html)

hoov7888 02-15-2013 08:21 PM

6.5 trigger seems to be not catching?
 
Hey guys, just got a used 6.5 and the trigger sometimes won't fire even tho the auto trigger timing is set up perfect..... It feels like the trigger sear isn't really catching? I move then gun around a bit and recock it and then it seems to fire normally. Other times a pull the trigger all the way back and it feels like it barley catches and fires. Any thoughts?

shredxcam 02-15-2013 10:49 PM

Is the trigger worn out where the cam rolls?

senghing27 02-15-2013 10:55 PM

Quote:

Originally Posted by shredxcam (Post 2626483)
Is the trigger worn out where the cam rolls?

That would be my first guess. Pull out the trigger and check for excessive wear.

hoov7888 02-16-2013 12:10 AM

Thanks guys, ill check it out when i get home

Talfuchre 02-16-2013 10:29 AM

This can cause this for sure - it is one of the most FRUSTRATING things to diagnose - because it is periodic.

Look for a divot in your trigger. If it is there - order another. If you need me to post pics of a worn trigger - let me know.

TF

hoov7888 02-16-2013 04:47 PM

That would be very helpful. I took the trigger out and there was a bit of grime on the roller. Also some wear, I'm thinking I probably need a new one but I'd love a picture to confirm that.

Also, I think im missing a pin that holds in the trigger rod. Correct?
[IMG]https://farm9.staticflickr.com/8233/8...44dbf7923d.jpg
IMAG0103 by hoov7888, on Flickr[/IMG]

tac0cat 02-16-2013 04:53 PM

Could it be your hammer lug not dropped low enough? Have you taken apart the lower tube recently?

Talfuchre 02-16-2013 05:13 PM

Hoov - indeed you are. Clean the whole thing - drop in an expedient pin (Thin paper clip or a guitar string will work for now) and see what happens.

TF

hoov7888 02-16-2013 05:51 PM

Quote:

Originally Posted by Talfuchre (Post 2626985)
Hoov - indeed you are. Clean the whole thing - drop in an expedient pin (Thin paper clip or a guitar string will work for now) and see what happens.

TF



I have to pull the trigger alllll the way back before the trigger sear releases...it just doesn't feel like its releasing like it normally should.

Could the missing pin be causing this or am I in need for a new trigger? Thanks TF, I appreciate it!

SeuDog 02-16-2013 09:44 PM

Quote:

Originally Posted by hoov7888 (Post 2626350)
Hey guys, just got a used 6.5 and the trigger sometimes won't fire even tho the auto trigger timing is set up perfect..... It feels like the trigger sear isn't really catching? I move then gun around a bit and recock it and then it seems to fire normally. Other times a pull the trigger all the way back and it feels like it barley catches and fires. Any thoughts?

Sounds like the marker has some wear with the grit you found on the trigger bearing. Check your sear spring. See if it is at the right height and raising the sear properly and consistently. The sear spring is the same as the valve spring.

If it is not the sear spring then take a look at the sear. Call CCM. Speak to Mel or Rod. Ask for the new hardened sear. The hardened sear is preferred and resist wear. TF is right. If the sear is worn, then the height of the sear will be lower affecting performance.

Lastly, check that trigger one more time. Get a magnifying glass and examine and see if it is cracked around the roller ball on that trigger. If it is, then that needs to be replaced. Nothing more irritating than a cracked trigger.

Good luck.


All times are GMT -4. The time now is 05:59 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO
© MCB Network LLC