mcarterbrown.com
 

Reply
 
Thread Tools Search this Thread
Old 04-19-2012, 07:28 PM   #1 (permalink)
Newbie
 
Join Date: Jun 2009

X Valve Leak

I need some help from all the experts on this site. I have had this X Valve Mag for about a year, never had a problem. Finally got a Ninja SHP tank and took it out this past weekend. Shot great until half way thru the day then it proceed to go full auto/burp all the air out. I thought that I was low on air so I refilled but still had the same problem. Take it home clean it up, take apart and cant find anything wrong. When I air it up it leaks however it now has a new problem after airing it up the trigger does nothing. Likes its not catching let alone stopping any air flow (on/off)

Any help/guidance that you can provide would be appreciated.

Thanks.
de3plus is offline   Reply With Quote
Old 04-20-2012, 06:39 PM   #2 (permalink)
Post Whore
 
Join Date: Oct 2010
Location: Minnesota!

CCM Fan
posted on AO too... sounds like an on/off issue, check your top oring
__________________
sQuidvision is offline   Reply With Quote
Old 04-20-2012, 07:31 PM   #3 (permalink)
Newbie
 
Join Date: Jun 2009

Tried that and basically did the same thing. Inspected/cleaned and relubed the orings. Put it back together, no leaks until I pulled the trigger. Then it leaked and the trigger stopped..no pressure. Turned the ASA off then back on and it went full auto and the trigger didnt work. Like the trigger had no air pressure.
de3plus is offline   Reply With Quote
Old 04-20-2012, 08:22 PM   #4 (permalink)
MCB Member
 
Spider!'s Avatar
 
Join Date: Dec 2008
Location: Houston, TX

Make sure your on/off pin is still as long as it should be (about .750). I keep finding short and broken ones lately.
__________________
My Feedback
Spider! is online now   Reply With Quote
Old 04-20-2012, 10:19 PM   #5 (permalink)
Formerly known as DMex
 
Ando's Avatar
 
Join Date: Jul 2009
Location: Glen Burnie, MD.

Turn your velocity up. If it's too low, It will piss out the barrel. When you put everything back together you might have not turned the velocity up enough.

Ck your oring on your reg pin assy. They might have gone Tango Uniform.

Clean everything with Qtips and oil everything manually.
__________________
WTB NOXX Tac1 Springfeed and Javelin Twister Barrel...PM Me!!!
Ando is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Air Gun Designs

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 07:31 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC