mcarterbrown.com  

Ask The Experts You ask the tough questions

Reply
 
Thread Tools Search this Thread
Old 05-08-2006, 09:03 PM   #11 (permalink)
Born again
 
mustangii's Avatar
 
Join Date: May 2006
Location: Warrensburg MO
Send a message via AIM to mustangii

yeap lots of us rm nuts at beog.org
edm
mustangii is offline   Reply With Quote
Old 05-09-2006, 06:40 PM   #12 (permalink)
MCB Member
 
Murph's Avatar
 
Join Date: Mar 2006
Location: Southern New Hampshire

Fan of EMR
Okay, I just don't get it. I gave it a full teardown, changed EVERY seal in it, cleaned every part off and reapplied a tiny bit of oil (Tapped the nozzle on my finger until it was a little wet with oil and rubbed it on the parts.) It still doesn't hold air. It leaks out of everywhre, predominantly below the regulator housing, which I don't get why, the LPR hose is on quite securely at both ends, I made sure I didn't overtighten the valve set screw, I did everything that was perfect. I must be missing a couple parts, because I can't get it to hold air to save my freakin' life!
Murph is offline   Reply With Quote
Old 05-09-2006, 07:26 PM   #13 (permalink)
Thick
 
HurtCow's Avatar
 
Join Date: Mar 2006
Location: Rocklin, CA
Send a message via AIM to HurtCow

CCM Fan
AKA Fan
Palmers Fan
One thing to keep in mind: Rainmakers suck.

Are the 2 o-rings that go over the regulator housing where it fits into the body intact?

Welcome to the sometimes rewarding, often frustrating world of RM ownership.
HurtCow is online now   Reply With Quote
Old 05-09-2006, 07:35 PM   #14 (permalink)
MCB Member
 
Murph's Avatar
 
Join Date: Mar 2006
Location: Southern New Hampshire

Fan of EMR
2 O-rings? There's only one on mine. Then again it IS a 98 (sn. 905 if that's any help.)
Murph is offline   Reply With Quote
Old 05-09-2006, 07:53 PM   #15 (permalink)
done
 
Join Date: Apr 2006
Location: nj
Send a message via AIM to Rainman229

at this point you three choices

a) continue asking questions. and probaly end up bald like me.

b) give up and sell it

c) send to me with 20 bux plus return shipping and have it fixed. hehee


but realy try this get a small spray bottle fill it about a 1/4 with straight dish soap, then fill the rest with water slowly. once it's filled shake it up. then strat spraying the body were you think the leak is. as it's gassed up. also have your frame off as you do this. just pinch off th lp hose. so you can have the mac off. you should find were the leak is real fast this way.
Rainman229 is offline   Reply With Quote
Old 05-12-2006, 01:04 PM   #16 (permalink)
MCB Member
 
Murph's Avatar
 
Join Date: Mar 2006
Location: Southern New Hampshire

Fan of EMR
Yep found the leak. It was right under my nose. None of my impressions after changing the seals out were right. I was under the impression that most of it was from the low pressure regulator. Nothing there. Where the bulk of the leaking is is from the crack between the regulator assembly and the rear of the lower reciever. Even changing the seals didn't help this out. I knew there was too much play there to keep a good seal. This would probably also explain why there's no 'earth shattering kaboom' when I 'fire' the marker, there's not enough source pressure to the LPR to get the hammer/sear over the pin where it trips it and fires the paintball. Are there any quick fixes so I can at least play a round with it before sending it out for repairs?

[Edit] Threw an O-ring over the regulator body where it connects with the rear of the lower reciever. Holds air now except for a very small, almost unnoticable leak from the lower bolt that holds the regulator in. I don't know why the HELL there is a leak there, but there is.

Last edited by Murph; 05-12-2006 at 05:01 PM.
Murph is offline   Reply With Quote
Old 05-12-2006, 10:41 PM   #17 (permalink)
done
 
Join Date: Apr 2006
Location: nj
Send a message via AIM to Rainman229

put some loctite on the oring for the lpr mount. and a little on the screws. see if that helps.
Rainman229 is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » Ask The Experts

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 03:19 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC