mcarterbrown.com
 

Tiberius Arms Everything Tiberius

Reply
 
Thread Tools Search this Thread
Old 06-25-2013, 08:24 PM   #1 (permalink)
Newbie
 
Join Date: Jun 2013

need tac 8.1 help!

hey guys, I'm new to this whole forum, so hope I'm doing this right. I have a tac 8.1 that has been working fine for me for a number of games, but last time I went out it would jam every other shot, it seemed that it couldn't get any air. after trying a few things I did manage to narrow it down to being I think the valves in my mags, because I tried a different mag and it seemed to work fine. that being said, does anybody know how to either stop my valves from jamming, or where I can buy new ones? any help would be greatly appreciated!
baseballmonkey is offline   Reply With Quote
Old 06-25-2013, 08:48 PM   #2 (permalink)
Furries are EVERYWHERE :3
 
Stripes's Avatar
 
Join Date: Dec 2007
Location: Palatine IL

it's much more likely to be a problem with the marker, the chance that basically all your mags have the same problem at the same time is slim to none
you can always try oiling your mag seals, but I would check your barrel detentes for wear, and make sure they're there, partial double feeding could cause problems too
is it "chuffing" or what?
how exactly is it jamming?
__________________
Quote:
I love sucking the juice out of pickles. -slowerpig81
Stripes is offline   Reply With Quote
Old 06-25-2013, 08:49 PM   #3 (permalink)
MCB Member
 
bob_wuzza's Avatar
 
Join Date: Nov 2008
Location: Grande Prairie AB

Best way to learn to fix is to jump right in!
But to save you the trouble of losing parts and in case you do:

Tiberius Arms Magazine - YouTube
Tiberius Arms Factory Parts - T8.1 Parts - T9.1 Parts

Voila!
__________________
Big Whoop, I'm spooning a Barrett .50 cal, I could kill... a building!!! - Sterling Archer
Feedback
bob_wuzza is offline   Reply With Quote
Old 06-26-2013, 12:50 AM   #4 (permalink)
Newbie
 
Join Date: Jun 2013

it happens with two of my four mags, but I've always used these two for the most part, leaving the others as mostly just backups, so they don't get used much. I've tried oiling them regularly, but that doesn't seem to fix or change anything. whenever I shoot once, it will work just fine, coming out at regular velocity and everything. as soon as I go to pull the trigger again though, the gun is dead. it's like pulling it when there isn't even a mag in it, and the only way to put out another shot is to eject the mag, reload it into the gun, and then I get another shot with it, but again, only one. this didn't seem to happen though when I tested one of my spare mags.
baseballmonkey is offline   Reply With Quote
Old 06-26-2013, 11:08 PM   #5 (permalink)
all work
 
Join Date: Jan 2011

If you suspect the magazine valves then tear those bad boys down. Clean, inspect, lube and reassemble them and see if the problem is resolved.
Nightstar is offline   Reply With Quote
Old 06-26-2013, 11:33 PM   #6 (permalink)
Newbie
 
Join Date: Jun 2013

tried that already, but since you can't take the valves themselves apart (unless there is something I'm
missing and there is a way to do so?) it didn't seem to change anything
baseballmonkey is offline   Reply With Quote
Old 06-26-2013, 11:48 PM   #7 (permalink)
all work
 
Join Date: Jan 2011

Hmm, on page 8 of my T8.1 manual there is an exploded view of the magazine valve. Now I haven't dissasembled one myself but it seems like all you need is a flat-bade screwdriver and an adjustable crescent wrench.
Nightstar is offline   Reply With Quote
Old 06-27-2013, 01:00 PM   #8 (permalink)
Tiberius & Guerrilla Rep
 
Join Date: Nov 2012
Location: Torrance, CA

http://www.youtube.com/watch?v=ceX3JwnYKpg

Tiberius Arms Magazine - YouTube
__________________
Tiberius Arms & Guerrilla Air
_______ __

2717 Ferguson Road
Fort Wayne, Indiana 46809

260-478-2500
service@tiberiusarms.com

Last edited by Gio24dude; 06-27-2013 at 01:04 PM.
Gio24dude is offline   Reply With Quote
Old 06-28-2013, 08:52 AM   #9 (permalink)
Furries are EVERYWHERE :3
 
Stripes's Avatar
 
Join Date: Dec 2007
Location: Palatine IL

That's a good disassembly video
One thing to note... Since brass is so soft, I use a small Allen wrench to span the two slots in on the valve face instead of marring it up with a flathead screwdriver

Just a thought
__________________
Quote:
I love sucking the juice out of pickles. -slowerpig81
Stripes is offline   Reply With Quote
Old 07-05-2013, 09:06 PM   #10 (permalink)
Newbie
 
Join Date: Jun 2013

took the valve apart as much as possible and found it was jammed, so I freed it and soaked it in oil, seems to be functioning perfectly again. thanks guys!
baseballmonkey is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Tiberius Arms

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 08:19 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO
© MCB Network LLC