mcarterbrown.com  

Reply
 
Thread Tools Search this Thread
Old 01-24-2018, 02:02 PM   #1 (permalink)
Newbie
 
Join Date: Dec 2017

LVL 10. Leak down barrel.

So I’m experiencing a slight, minor leak down the barrel with my level 10 kit installed. I understand that a leak down the barrel that stops when the trigger is pulled and held can be traced to the power tube oring. I am on the smallest carrier, no shims.

I’ve tried other carriers in the event that they were labeled wrong, but they leak worse. I tried many many configurations, shims, no shims, new o ring everything. It didn’t leak when I first installed it, but on my first trip to the field the o ring must have broke in as I was shooting and the minor leak started. The level 10 was working great. Chuffing like it should. Never broke a ball or locked the bolt, so I feel like I’m close.

It was happening on my initial setup with a classic valve. I have since moved to and eMag valve but the same minor leak persists.

The carrier I’m using has no lines or dots. The troubleshooting steps I’ve read indicate this means I should step down to a smaller powertube oring carrier, but there are no smaller ones.

When I wiggle the barrel or press on the valve the tone of the leak changes so I have a feeling it has to do with the carrier.

Anyone have any ideas?
ichiban_al is offline   Reply With Quote
Old 01-24-2018, 02:09 PM   #2 (permalink)
Voted most ball-fondliest
 
freedummy's Avatar
 
Join Date: Aug 2012
Location: Calgary, Alberta

If youre down to the smallest carrier and still leaks, then its time for a new powertube oring (I think thats the name, small white one in the back of the carrier.) Don't worry about the shims, they're for a different issue most mags won't have.

New oring in largest carrier it will fit without leaking. As the oring breaks in, it may leak again - then you move down to the next smaller carrier.

EDIT: Sorry, just saw you said you already tried that oring? Your symptoms still seem to point to that one (leak changes when you press on the valve)... Did you try the oring on the powertube tip too?
__________________
Quote:
Originally Posted by The Flounder View Post
We don't do easy here! Here we do different and not done before!
My feedback: MCB / eBay

Last edited by freedummy; 01-24-2018 at 02:18 PM.
freedummy is online now   Reply With Quote
Old 01-24-2018, 02:13 PM   #3 (permalink)
Newbie
 
Join Date: Dec 2017

Right I figured so, however this was a brand new powertube o ring, right out of the box of a new lvl 10 kit. So I followed the tuning instructions that said not to change the power tube oring, only the carrier size and shims

Last edited by ichiban_al; 01-24-2018 at 02:22 PM.
ichiban_al is offline   Reply With Quote
Old 01-24-2018, 02:28 PM   #4 (permalink)
Voted most ball-fondliest
 
freedummy's Avatar
 
Join Date: Aug 2012
Location: Calgary, Alberta

Might just be a bad oring, new or not... Stranger things have happened. Do you have another one to try?
__________________
Quote:
Originally Posted by The Flounder View Post
We don't do easy here! Here we do different and not done before!
My feedback: MCB / eBay
freedummy is online now   Reply With Quote
Old 01-24-2018, 02:30 PM   #5 (permalink)
trophy husband
 
rawbutter's Avatar
 
Join Date: Feb 2012
Location: Fredericksburg, VA

Quote:
Originally Posted by ichiban_al View Post
Right I figured so, however this was a brand new powertube o ring, right out of the box of a new lvl 10 kit. So I followed the tuning instructions that said not to change the power tube oring, only the carrier size and shims
I've had this happen with brand new o-rings before. It happens. Either the o-ring was made a little bit too small, or it's damaged slightly. The tolerances on these parts are so freakin' small, I'm honestly surprised it doesn't happen more often.

I would try another new carrier o-ring. Chance are that will fix the problem.
rawbutter is offline   Reply With Quote
Old 01-24-2018, 02:39 PM   #6 (permalink)
Newbie
 
Join Date: Dec 2017

Once I get more air I値l try swapping in a new carrier oring. I知 pretty sure I have 2 more fresh ones that came with it. I値l report back here with the results.

I知 not very hopeful since I kinda feel like I tried that already in the mix of tuning the kit, but I don稚 remember exactly.

We値l see soon, thanks for the respnses so far, hopefully we can figure it out
ichiban_al is offline   Reply With Quote
Old 01-24-2018, 02:55 PM   #7 (permalink)
mag shooter
 
superman's Avatar
 
Join Date: Jun 2007
Location: Charleston, SC

AGD made smaller carriers because the oring sizes have shrunk.
__________________
I buy Automags and Parts: if you need cash shoot me a pm

My shop page: Bearded Works

feedback(https://www.mcarterbrown.com/forums/f...-feedback.html)
superman is offline   Reply With Quote
Old 01-24-2018, 04:26 PM   #8 (permalink)
MCB Member
 
Join Date: Feb 2014
Location: Oklahoma

Quote:
Originally Posted by superman View Post
AGD made smaller carriers because the oring sizes have shrunk.
what he said.
vintage is offline   Reply With Quote
Old 01-24-2018, 04:27 PM   #9 (permalink)
MCB Member
 
Join Date: Feb 2014
Location: Oklahoma

if it still leaks with a new o ring call AGD and talk to Tim. they discovered that the current batch of o rings is smaller than standard and they made up 2 new carriers to take care of this problem.
vintage is offline   Reply With Quote
Old 01-25-2018, 08:54 PM   #10 (permalink)
Newbie
 
Join Date: Dec 2017

Okay, a little embarrassed to say but I think I resolved the issue.

I swapped in a new powertube oring and noticed it still leaking. So I removed everything and started from the ground up...

Then I realized instead of putting in the hard plastic washer behind the powertube carrier I had in the original level 7 soft oring that goes all the way in the back behind the spacer :0

I took that out, swapped it with a hard plastic washer, put it all back together, and now Im running leak free....for now...

Thanks everyone. Sorry it ended up being a stupid fix.
ichiban_al is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » Air Gun Designs

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 03:53 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO
© MCB Network LLC