mcarterbrown.com  

Reply
 
Thread Tools Search this Thread
Old 02-14-2015, 07:43 PM   #1 (permalink)
MCB Member
 
Marbo40k's Avatar
 
Join Date: Oct 2007
Location: Chugiak, Alaska

B2K suffering from terrible shootdown...

So I picked up a BKO (2k2 I believe) for a coworker a few days ago and put air to it when it first arrived. A couple quick dry fire shots, a few over a chrono and I thought it was good to go. Tried it out at the field today and it cannot do more than 4 bps before the velocity drops off to nothing.
I know the ICD regs have a reputation for erratic behavior so I swapped it out for a Bob Long Torpedo. Still horrible shoot down. Swapped that for a Hyper 2 only to have the same result.
I rebuilt the entire thing (literally replaced every Oring and seal) lubed it up and still no matter what reg I use the drop off is terrible. I can watch the gauge go from 225 down to 0 in 4 quick shots.
I also tried 7 different tanks thinking there may have been a problem with one o them or something.

Anyone have any suggestions as to what I can do to fix this?
Everything is set to factory settings per the Manual.
__________________
My feedback: https://www.mcarterbrown.com/forums/f...-feedback.html

FYI: USPS Flatrate IS the same price when shipping to Alaska...

Last edited by Marbo40k; 02-14-2015 at 09:53 PM.
Marbo40k is online now   Reply With Quote
Old 02-14-2015, 08:21 PM   #2 (permalink)
Plumper Pumper
 
Tippymann76's Avatar
 
Join Date: Aug 2006
Location: Indianapolis

CCM Fan
a buddy of mine had a problem with his b2k4. you may want to look into replacing the LPR.
Tippymann76 is offline   Reply With Quote
Old 02-14-2015, 08:22 PM   #3 (permalink)
MCB Member
 
capitalpaintball's Avatar
 
Join Date: Jul 2006
Location: Coventry R.I.

If it does it with 2 different regs then it might be your asa. some tank regs can be choked by the asa. if its a non on/off, try backing the tank off a bit. if it is an on/off , back off the knob a bit.
certain asa pin depressors are the same size as the hole for the pin on the tank regs. if they go to far they plug the air hole.
__________________
my feedback:
capitalpaintball is offline   Reply With Quote
Old 02-14-2015, 09:00 PM   #4 (permalink)
MCB Member
 
Marbo40k's Avatar
 
Join Date: Oct 2007
Location: Chugiak, Alaska

Hmmm I haven't tried a different ASA yet... I'd did try backing the tank off a bit but no dice. I'll swap it out and try that and I'll post back shortly...
__________________
My feedback: https://www.mcarterbrown.com/forums/f...-feedback.html

FYI: USPS Flatrate IS the same price when shipping to Alaska...

Last edited by Marbo40k; 02-14-2015 at 09:09 PM.
Marbo40k is online now   Reply With Quote
Old 02-14-2015, 09:12 PM   #5 (permalink)
MCB Member
 
Marbo40k's Avatar
 
Join Date: Oct 2007
Location: Chugiak, Alaska

Okay tried two different ASAs and no go. Not sure where to go next.

Tippyman76: do you know exactly what LPR your buddy went with?
__________________
My feedback: https://www.mcarterbrown.com/forums/f...-feedback.html

FYI: USPS Flatrate IS the same price when shipping to Alaska...
Marbo40k is online now   Reply With Quote
Old 02-14-2015, 09:44 PM   #6 (permalink)
Fear the Beer!
 
forstgump's Avatar
 
Join Date: Jan 2008
Location: The O.C. 53154

It's a bko or bushy? Your (2k2) is throwing me off. The hpr losing pressure?
__________________
Badges? We don't need no stinking badges!
MCB Feedback
Icd-0 Feedback

Quote:
Originally Posted by melkson View Post
After I found out I had a screw loose, he gave me a good short screw. Filled my hole completely.
forstgump is offline   Reply With Quote
Old 02-14-2015, 09:51 PM   #7 (permalink)
MCB Member
 
Marbo40k's Avatar
 
Join Date: Oct 2007
Location: Chugiak, Alaska

Quote:
Originally Posted by forstgump View Post
It's a bko or bushy? Your (2k2) is throwing me off. The hpr losing pressure?
Whoops I'm sorry. Yeah it's a bushmaster b2k. I'll fix the title.

And for the HPRs the pressure just drops dramatically when shooting. The gauge reads 225 and then drops to 0 in about 4 rapid shots. Stop shooting and it re charges quickly and when shooting about 2 bps it works fine. Anything faster and it dies.
__________________
My feedback: https://www.mcarterbrown.com/forums/f...-feedback.html

FYI: USPS Flatrate IS the same price when shipping to Alaska...

Last edited by Marbo40k; 02-14-2015 at 09:56 PM.
Marbo40k is online now   Reply With Quote
Old 02-14-2015, 10:15 PM   #8 (permalink)
pk5
Stardust Memory
 
Join Date: Sep 2006
Location: San Diego

CCM Fan
Brass and Wood Fan
RTP Fan
Then you probably need to replace your hpr. The stock one is a hit or miss.
pk5 is offline   Reply With Quote
Old 02-14-2015, 10:17 PM   #9 (permalink)
pk5
Stardust Memory
 
Join Date: Sep 2006
Location: San Diego

CCM Fan
Brass and Wood Fan
RTP Fan
Oops. Ignore what I said.

Does your hpr work fine on other guns? Maybe check your macro line ?
pk5 is offline   Reply With Quote
Old 02-14-2015, 10:26 PM   #10 (permalink)
Active Member
 
vantrepes's Avatar
 
Join Date: Nov 2007

There's a restriction somewhere between the tank, and the reg output.
If I recall correctly, the gauge on the B2k is mounted on the ASA, correct?
Then your problem is before the gauge, so it's either the guns ASA, HPR, hoses, tank ASA, or the tank its self.
I'd suggest taking a really close look at the ASA. Make sure you aren't screwing the inline reg in far enough to block the air passage into the gun at the ASA.
vantrepes is offline   Reply With Quote
Reply

  mcarterbrown.com » Paintball » The Armory » ICD

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -4. The time now is 12:37 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO
© MCB Network LLC